GRBL 3018 Pro Mirror Image control problem

I have GRBL 3018 Pro. I’ve added limit switches to all six points of contact. I’ve set $23=0, and I am ok with home being 0, 0 in the upper right corner. I’ve set my origin to the upper right corner (experimented with all four locations.) All that is fine. The problem comes to movement of the laser, in that it is inverted. With the laser in the upper right corner, I can only use the up and right commands otherwise I get endstop errors. When clicking up, the laser moves down and the laser position symbol goes up. When clicking right, the laser moves left and the laser position symbol goes right. (up and right off of the working grid)

If I change the point of origin to bottom left. The direction buttons match the movement of the laser, but the position indicator now goes down and left off of the working grid.


$3 is a setting that allows you to reverse the direction of any axis.

Given $3=2, adding 4 to that number (changing it to $3=6) would keep your Y-axis as it is (inverted) and would add the inverted Z-axis.

In the console window enter the following:
then press enter and test your newly inverted Z-axis.

More information available here if you’re so inclined.

I tried all $3 codes and I’m still having the same issue. Regardless of where it homes, I line up the origin to match. I can only move the laser in the directions that take the laser off the grid. It is not a Z issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.