GRBL 4th Axis, Lightburn, Rotary axis, GRBL Mega 5X

I have just started to use Lightburn with a newer version of GRBL intended for the Mega 2560 board plus or minus the RAMPS shield. It is version 1.1L and is intended for true 4th (and 5th and 6th) axis movements. It is available on Github. Search for GRBL Mega 5X. It has Laser mode of course. It can easily be loaded with Arduino IDE or with the Hex file and XLoader.
In the past I had some success mapping a curved surface and burning to that with a ‘fake’ 4th axis using one of my Uno linear axes as a rotary axis. I would tell Lightburn to use Y as the rotary for example.
Using the Mega 2560 board, I have set up the A axis in GRBL under $133 and $134 and calculated the proper number of steps for my regular stepper direct driving my 4th axis - 200 steps, 32 microsteps divided by 360 degrees results in a ‘number’ for A of 17.778 steps (per degree I think). At any rate the piece moves accurately with G1 A___ F___ where A is in degrees. It looks like the prior GCode I created with Lightburn is moving things properly.

It looks like Lightburn will handle this properly as a 360 degree movement device although in setup when I select A axis the 360 is greyed out and the settings is still looking for object diameter and/or circumference. I am wondering is this is just to help scale the image to the object and the 360 is defaulted? Is this a true use of the 4th axis? Are A commands to GCode properly created?

Hi I would like to use the firmware grbl 5x loaded it on the arduino Mega 2560 and RAMPS 1.4. load the firmware with IDE and everything is ok, I try the connection with lightburn but nothing happens. Where am I wrong? Thank you!


I have Lightburn running right now on an Arduino Mega 2560 with a RAMPS 1.4 card plugged into it. No endstops because I don’t need them. I have DRV8825 Stepper drivers plugged into ti. This runs without any problems. These have to be properly adjusted for power.
You will have to check all your connections, disconnect any endstops, put the tool in the middle of your machine and try turning the machine and Lightburn on.
If you haven’t selected a COM port (bottom right of Lightburn panel) the program can’t communicate with the control board. Even the USB cable has to be checked to be sure it is plugged in properly. Select Arduino GERBIL(GRBL) as your operating system. Connect to the board at 115000 BAUD speed under Device settings. If this speed is wrong it won’t connect.
Next go to Console Tab at the middle right of the Lightburn screen. If connected and GRBL is loaded correctly, there should be something like:
Grbl 1.1l [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

In the command line below this window type $$ and the GRBL settings should scroll past in the window above. I think you got this far. If not, you are not connected properly to the Mega Board. The last setting of $$ should be $134 which is the max degrees (360) for the Rotary Axis.
Click on the Move tab. If you can’t see it, Right click the mouse with the cursor above the right side windows and you should get a Choice window to select Move from - check it. Under the top window there should be a Move tab, click that and a standard move console should appear. Try to move the XYZ and Rotary axes there.
If you can communicate with the board but still no movement, you have to troubleshoot your Stepper connections. That all depends on how carefully you set up your Stepper drivers and the RAMPS board. Make sure the little stepper drivers are plugged into the RAMPS in the proper direction. The DRV8825 and more common A4988 plug in differently. Check Github for lots of information.
If all of this is correct, you have to start checking your Device settings in LIghtburn. I have found in the past that my speed settings were too slow. Start with something like 1000 for X and Y and try not to crash your machine ha ha. Pull the power plug if necessary.
Only when it is moving properly should you try to set up endstops. GRBL prefers those to be NO (normally open).
Good luck

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.