GRBL CNC 5.5 laser won’t fire


As a newbie to CNC I’m hoping to get some helpful advice on setting up my laser. I’ve gone through all the forum posts on this and so far nothing has helped. Here’s the issue and the particulars of my situation.

I have a Mostics 2 in 1 desktop CNC router and laser machine running GRBL 1.1
My laser is a 5500mW Mostics laser that came with the kit.
My computer is a MacBook Pro running macOS Mojave
LightBurn successfully discovers the machine and all the axis movement controls work properly…including the z axis.
The fire laser button is set to green in LightBurn but does not activate the laser.
The laser is functioning because I can push on the pressure switch on the laser control board to turn on the laser…and the laser fires properly. With my version the laser control board is not attached to the laser itself.
I have tried 1000 and 12000 for $30…no change to the issue
I have ensured that the $30 setting equals the S-value in the device settings
The spindle motor is removed and the wiring is unplugged from from the control board.
I have tried the functioning with both the external controller attached and removed.
The wiring from the laser is plugged into the correct terminals (fan and laser) on the control board. I have confirmed they are not switched.
The control board is connected to the correct terminal on the control board.
The control board is turned on.

Can anyone help determine what I have done wrong here and help me to get my laser to fire?

Much appreciated,

Did you go through the Lightburn grbl setup? It explains what these ‘registers’ are used for and what Lightburn expects.

Did you enable the laser to fire in the Edit → device settings? (I think that’s where it’s at)

How do you know this is correct? In other words can you produce some kind of documentation to help us assist you. A photo, link to the product, what pin is connect to what.

These lasers generally take ground, power and a PWM. PWM controls the lasers output. If it fires manually from the control board that leaves the PWM control signal.

Do you have any kind of volt meter? A digital volt meter may allow you to tell if the pwm is functioning.


I was able to verify the connections in a couple of different ways. The terminals on the laser control board are labeled fan and laser. I have attached the color coded connectors to the corresponding connectors on the control board. When I connect the fan wires to the fan connector, the fan turns on. This tells me I have this connection correct. By default the other must be the laser. Also the laser control board gets power and signals through the main control board of the CNC. When I activate the manual pressure switch on the laser control board the laser fires. This tells me three things. First, the laser is getting power from the main control board. Secondly, the laser functions. Finally, this tells me the laser control board is communicating with the diode laser.

I could be wrong but I think this must be a setting issue.

Thanks for the suggestions.

Sorry Jack….with regard to the GRBl setup….yes I’ve gone through all of these. It was very helpful to understand what each one does. Can I load photos to this forum? If so, I can load pics of my setup and settings in case I have missed something.


Yes you should be able to ‘drag and drop’ it here.

Maybe I’m confused.

The machines I looked at show a Woodpecker control board. These don’t have a ‘fire’ button that I was aware of.

You stated you had an external board for the laser.
Is this where the manual ‘fire’ button is?
Or is it on the grbl control board?

Hi Jack,

I’ve added a few photos. Let me know if they come through ok. I’ve tried to get in close so you can see the terminal labels and pressure switch on the laser control board. Does this help? It looks like I’m limited to four photos….I’ll try to send the others in a separate reply.

Here is an overall view of the setup. Let me know if there are some particular details that would be helpful.

Actually you are pressing the button on the external laser board to fire the laser.

That button is not the PWM control, it may cause your laser to fire, but it doesn’t indicate the PWM is getting to the laser board from the Woodpecker or the laser board is handling it correctly.

On the laser head itself, is one of the two connectors for the fan? Generally the fan runs off the laser head supply voltage, but who knows…

I’m guessing you don’t need the 12v from the Woodpecker, just ground and PWM. That’s how mine was assembled, by me… Leave it as is until we see some reason to think otherwise. It’s not smoking so it’ll probably be ok. :slight_smile:

Is the white wire going to the laser connector on the Woodpecker also identified on the laser head as PWM input? And the black to ground?

Generally it looks like the hardware is connected properly.

Do you have access to a volt meter? You can read the voltages of the PWM with respect to the Woodpeckers ground. If the voltage varies when you vary the output power it’s probably working.

DO NOT SHORT between the PWM and the other terminals, especially the 12v one. Ground short probably wouldn’t be good either.

That’s about all I can add at this point. Good luck… :slight_smile:

Thanks for all your help Jack. Just when I was about to give up I found the problem. I noticed that a piece of black plastic on the laser board pressure switch was lifting up slightly when the switch was raised. On closer inspection I could see that this plastic should have engaged with plastic clips to keep in in place. I used a screw driver to push the retainer down to engage with the clips. Now the switch makes proper contact and the laser works fine. I hope others with the same problem find this posting because it was just dumb luck and a bit of persistence that helped me find this. Thanks again for your support.

Rick, no perspiration… I’m glad you found the issue and best of all it was a cheap quick fix. :slight_smile:
Thanks for letting us know the resultant fix. Mark the thread ‘solved’ if you’re happy…

Take care, happy lasing :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.