GRBL Homing Issues

Hi, I just installed my GRBL controller to my Orion Motor Tech 40W K40 Laser. When following the set up instructions on the LightBurn website it shows that the homing location should be “Front Left”. I have input that and when I home my laser it goes to the wrong spot. Not sure how to fix this issue so it will home to my trigger switches.

Thank you,

The homing location is wherever the limit switches are, and you can tell GRBL to reverse one or more of the axis directions to get it there.

GRBL, when configured for CNC use, assumes that the switches will be rear-right, and then you’ll manually zero the machine to the workpiece.

There’s a compile-time flag that you can set when building GRBL to tell it otherwise:

// After homing, Grbl will set by default the entire machine space into negative space, as is typical
// for professional CNC machines, regardless of where the limit switches are located. Uncomment this
// define to force Grbl to always set the machine origin at the homed location despite switch orientation.
// #define HOMING_FORCE_SET_ORIGIN // Uncomment to enable.

It’s an annoying hold-over from CNC use.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.