GRBL issue

I have purchased an 3 axis EleksMaker Mana v. 5.2 to test LightBurn with my 6W laser from Opt Lasers.
My problems are as follows:
When I run the EleksMaker booard with the GRBL (standard ?) I get 100% output to the laser @ 100% setting; however the laser does not turn off between cuts.
As LightBurn suggest to this problem I tried to run the laser with GRBL-M3.
Now the laser turns off between cuts but I only get about 1/3 of the laser power @ 100% setting.
I hope there is some one in here that can help me out.

Type $$ in console in Lightburn, and paste what your values are here. From what I’ve read in the past, you’re probably pushing your travel speeds too much, and it compensates by lowering power. With grbl 1.1f, you probably didn’t have $32 = 1.

You might not have the $30 setting correct, or matching the “S-Value Max” setting in the LightBurn Device Settings window.

Continuing the discussion from GRBL issue:

Hee are the values I get when I use the $$ command:
As you see there are no $30 or $32.


$0=10 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=0 (dir port invert mask:00000000)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=80.000 (x, step/mm)

$101=80.000 (y, step/mm)

$102=80.000 (z, step/mm)

$110=5000.000 (x max rate, mm/min)

$111=5000.000 (y max rate, mm/min)

$112=5000.000 (z max rate, mm/min)

$120=200.000 (x accel, mm/sec^2)

$121=200.000 (y accel, mm/sec^2)

$122=200.000 (z accel, mm/sec^2)

$130=5000.000 (x max travel, mm)

$131=5000.000 (y max travel, mm)

$132=5000.000 (z max travel, mm)


What’s your s-value max set to in Lightburn? It should be 255 with the M3 device I believe.

Hello again
Thanks for your assistance.
Perhaps I am just getting too old for this, when it becomes a problem just to communicate on this site.
Anyway, are your conclusion that this control board is obsolete for LightBurn and I should look for another card. ?
I am awaiting delevery of a Ruida RD RDC6442G - K40 from k40 for my k40 laser.
I the waiting time I tried to test LightBurn in a 3D printer setup with the EleksMaker Mana v. 5.2.
I purchased the Eleksmaker because it is shown on the LightBurn License page.
If I want to buy another board for my 3D Laser Engraver Setup what would you recommend.?

Thanks again

Hello Blake,
The s-value max set to 255 and has been so all the time as I have never touched it

Perhaps, but I hope it is not our responses that are gumming up the communication channel. :slight_smile:

Are you using GRBL-M3 Device in LightBurn? Ideally, you will want to update your firmware to GRBL 1.1f then use plain GRBL Device in LightBurn. You don’t “need” to change out your controller.

Here is another great resource for your setup.

As another member previously posted, "Scroll down to the bottom of the page, "operating instructions", and follow that. Once you have it working in elekscam, it should work in lightburn. Follow the instructions to the letter and that will get you up and running…"

There is also a group for these types of machines on Facebook and quite a few people there use LightBurn, so they might be able to advise you more.

The default Spindle Max setting I’m used to for older versions of GRBL is 255, but for new versions of GRBL it’s 1000. You could try changing yours to 1000 to see if it solves the “1/3rd output power” issue you’re having. It’s possible that your version of GRBL uses the higher value, and if it doesn’t help you can simply set it back to 255 and there’s no harm done.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.