GRBL Laser Acting Strange With Lightburn

grbl

(Leonidas Savvides) #1

Dear all,

We downloaded the trial version of Lightburn the other day to see if it will drive our GRBL 3018 well.

The software is really nice, but we have some strange things happening when we run it.

When we first load the software, the laser of our machine turns on full blast. The only way to shut it is to quickly pull off the usb that connects the machine to the pc, and then connect it again. This is strange thing number one.

Next, when Line mode is on, we can control the Cut Through mode by setting a Start pause time and an End pause time. This allows the laser to stop when moving from one burning point to another, leaving no tracing lines behind. The problem here is that when we change the mode to Fill or Line + Fill, the Cut Through menu disappears, and we haven’t found another way to make the laser stop when it’s moving from one burning point to another. As a result, when we try to burn on any mode besides the Line mode, the laser burns when moving from point to point burning also its path lines. This is strange thing number two.

Lastly, when we restart the software, the coordinates are wrong, the origin is not where we set it last. We have to basically reassign the origin every time. Also the software doesn’t remember our machine, so we have to assign that too every time.

I’m not sure what version of GRBL is running on my controller, how can I find out?

Thank you in advance,

AlienCat


(Rick James) #2

Type “$$” into the console and hit ‘Return’. Copy and Paste the output here.


(Leonidas Savvides) #3

Hello Rick,

Thank you for the reply, here’s what I got:

$$
$0=10
$1=25
$2=0
$3=5
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=800.000
$101=800.000
$102=800.000
$110=800.000
$111=800.000
$112=600.000
$120=30.000
$121=30.000
$122=30.000
$130=200.000
$131=200.000
$132=200.000
ok


(Rick James) #4

First, this is a good reference for all things grbl.

https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

And have a read through this to help with understanding common Grbl setups in LightBurn.

https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

I notice you have several issues with your current grbl settings that need to be changed to work with a laser.

You need to check your settings for $32 (laser mode) and $10 (reporting mode). They should be:

$10=0

$32=1

That is, $10=0 (report workspace position, not machine position) and $32=1 (laser mode, not spindle mode).

You may want to include those in any macro you set up to put your system in laser mode.

Home and Origin are not the same positions. Home is where your limit switches are, always. Origin is where 0,0 is, and there’s no requirement they be the same. After homing, and with the offset programmed as discussed in the documentation link above, if you type G0 X0 Y0 into the console and hit enter, wherever it goes is where your origin point is. Set the device origin in LightBurn to match it and you should be all set.

I see that your $30=1000 so make sure you have the same value set in ‘Device Settings’ window under the ‘S-value max’.

Let’s start there and you can report back with the results to these changes and we can go from there.


(Kinetic) #5

So I have a similar problem to this, the laser is making trace marks when it’s moving to a new cut position.

My S-value max is set accordingly, so I checked out the Gcode… and it looks like it turns on the laser and then leaves it on:
In this example, S300 is turning the laser on to 30%, and then at the bottom it sets it to S0 and turns it off.

NOWHERE else in the generated gcode does it turn the laser off.

So - question is, where is the option to generate gcode that turns the laser off inbetween cuts?

; LightBurn 0.9.02
; GRBL device profile, current position
G00 G17 G40 G21 G54
G91
M4
; Cut @ 5 mm/sec, 75% power
M8
G0X70.5Y111.5
G0Z0.3
G1X-0.03Y-0.56S300F300
G1X-0.08Y-0.55
G1X-0.14Y-0.53
.
.
.
G1Y2
G1X2
G1Y-2
M9
G1S0
M5
; return to starting pos
G0 X-72.5Y-103
M2


(Oz) #6

G0 moves turn the laser off, G1 moves have them on. If you use the same power setting for outlined shapes it’s not necessary to do otherwise. You likely don’t have laser mode enabled in GRBL - $32=1 in the console, or “Laser Mode Enable” in the Machine Settings.

If you don’t have that enabled, you won’t get correct behavior.