GRBL = line burning between shapes / GRBL-M3 = low power

Hi guys,

So, I’ve spent some time lurking on here. I’ve been using an Eleksmaker A3 pro with Lightburn for some time now but have grown out of the 5w laser module that came with it. Just replaced it with a 15w beast. (To me anyway. It might as well be the Deathstar by comparison!) Got a few problems I was hoping the community would be able to help with.

  • Using GRBL I was getting lines burned between shapes.
  • Looking through the forums I have read that with the Grbl 0.9i firmware installed on this new laser module I should use GRBL-M3
  • I’m now experiencing low powered burns and can’t identify why.

A lot of people experiencing similar problems talk about $30 on here but as you’ll see below, I don’t have that setting. You’ll see I’ve increased $120 AND $121 to 1500 as suggested in one thread but now improvement to the burn.

Anyone have any suggestions? Thanks in advance for your help.

$0=10 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=0 (dir port invert mask:00000000)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=80.000 (x, step/mm)

$101=80.000 (y, step/mm)

$102=80.000 (z, step/mm)

$110=5000.000 (x max rate, mm/min)

$111=5000.000 (y max rate, mm/min)

$112=5000.000 (z max rate, mm/min)

$120=1500.000 (x accel, mm/sec^2)

$121=1500.000 (y accel, mm/sec^2)

$122=200.000 (z accel, mm/sec^2)

$130=5000.000 (x max travel, mm)

$131=5000.000 (y max travel, mm)

$132=5000.000 (z max travel, mm)

With GRBL 0.9 you’re going to have a lot of trouble in general - Any time the power output value is changed the controller will pause, because it thinks it’s driving a rotary tool that has to speed up or slow down, not a laser that responds instantly.

The issue with low power is usually the S-Value Max setting in Edit > Device Settings in LightBurn. What is yours set to? For GRBL 0.9, I think the hardware range is 255, meaning you’d need to set it to that same value in LightBurn.

If you can upgrade the firmware in the device to 1.1f or later, you’ll get better results with a laser.

Hey Oz, thank you for replying!

I’ve gone to Edit > Device Settings and it’s set to 255.

Is there a good guide to upgrading (That’s also called Flashing, right?) the firmware to 1.1f that you can link me to? From what i’ve read it’s a bit of a risky maneuver…

Thanks for the advice, Oz!

Ok, so I’ve gotten GBRL 1.1h flashed onto this now.

Having a bit of a struggle with a few things now.

  1. it’s not nearly as powerful as it was previously
  2. it’s got a distinct judder on the Y axis which is skewing complex shapes and circles. After a bit more testing, the X axis moves smoothly, as well as on a diagonal but on Y axis it seems to get stuck.

Also, it’s measurements are pretty out. a 10mm square is coming out at 30mm

Here’s the code as it stands at the moment. Have I messed something up?


When you re-flash the firmware, it resets the settings. You’ll need to transfer the old ones to the new board, specifically these:

$100=80 (steps per mm on X - this is why the size is wrong)
$101=80 (steps per mm on Y)
$110=5000 (max speed in X, mm/min - this is why it’s slower & less powerful)
$111=5000 (max speed in Y, mm/min)
$120=1500.000 (x accel, mm/sec^2)
$121=1500.000 (y accel, mm/sec^2)

$130 and $131 should be set to the lengths of the X and Y axis, in mm

You’re an absolute hero, Oz, thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.