GRBL M3 - Fill Working but not Line

Hey all,

I have a bit of an issue and wondered if someone could help. I am using a WorkBee with Duet Ethernet board. I know that this board is not supported, but I would still really like to use LightBurn from gcode files manually.

I can get fill and image to work perfectly, but not line using the GRBL-M3 profile. Fill + Line or Line alone only turns the laser on for the first move if at all.

I drew a really simple filled box, 30mm x 30mm. Fill was great worked as expected, line did nothing.

Sample of line gcode:
; Layer C00
M3
G1Y30
G1X30
G1Y-30
G1X-30
M5
M9
G1S0

If I edit the gcode manually to this it works OK:
; Layer C00
M3
G1Y30S127
G1X30S127
G1Y-30S127
G1X-30S127
M5
M9
G1S0

I need an S value on every G1 line when the laser is on. Is there a profile that does this?

Alternatively is there a profile that supports M3 Sxxx / M5 wrapped commands e.g.:
M3 S100
G1Y30
G1X30
G1Y-30
G1X-30
M5

Thanks

Bumping for any input. Really want to use Lightburn as it does everything I want / need - just need some kind of steer on getting the output right so it is usable for me without needing to manually edit the gcode every time.

I am using the GRBL -M3 setup and if I draw a square I get this g-code:
G00 G17 G40 G21 G54
G90
; Cut @ 700 mm/min, 100% power
M9
M5
G0X0Y0
; Layer C00
M3
G1Y30S255F700
G1X30
G1Y0
G1X0
M5
M9
G1S0
G90
The first G1 has the S255 parameter. Not sure why your first G1 is not putting it there. Also, it is not specifying a feed rate like F700. Under Device Settings do you have a value for 's-value max"? Its almost like LB doesn’t know you have variable power/spindle. You might double check your $ parameters related to laser.

There is no profile currently that does this, no. The S parameter is supposed to be sticky, and then G1 and G0 differentiate between feed moves and travel moves (firing move vs non-firing). Are you saying the Duet requires an S param on every G1 line?

The Duet is an interesting little board. It does not have $ values as such. Rather additional M commands. It has two primary modes of operation, CNC Mode and Laser Mode. CNC mode uses the S param to control spindle speed - so it is basically always on as travel moves would either have a Z hop or be in open space, and you do not want to wait for the spindle to ramp up to speed after every move. Laser mode toggles the Laser as you suggest on G0/G1.

My lightburn trial has expired, but I will do some more meaninful testing with the sample that I have and provide more feedback.

I would love to get this working in some way as it would be useful for me, and thee duet community at large.

I was wondering about doing fill in Laser mode (as that works) and Line in CNC mode. I will have a play and put something more comprehensive up here.

We’re happy to extend your trial if you email us with the Trial ID.

All

Thanks for the help with this - looks like I have found the answer. I was missing the ‘sticky’ parameter! My fault. I will test again and revert if this works.