Green dot moves when "enable rotary" selected

I am very new at this. Trying to do a tumbler and when I “Enable Rotary” under tools the green dot goes from Current Position, center, center to off the grid. When I send to the LS 1420, I get a frame slop error. Its a 20 oz tumbler that tapers toward the bottom. When I select the image the green dot moves around and only on the image at the edge of the workspace. I have done CTRL A and selection box around the red dot but the only thing selected is the image. I have also made it small but still not sure what is happening.

Try to deselect everything, then ‘Select All’ (Ctrl + A, ⌘ + A on mac) to see if you have another small shape out there. You may find that the Origin is out there due to another non-selected shape.

Hi Rick,

I tried that and ended up finding a small little pea sized object near a node I edited. Not sure if that caused anything. I also ended up calling Boss. The gentlemen that helped me could not find what was causing the green dot issue as well. He ended up uninstalling and re-installing the software. The new issue I have is the Cuts/layers modes do not work. I select an object and try to change from line to fill and nothing happens. I also tried re-installing the software myself with no solution. I really love this software. I think its the most user friendly I have ever used. Just having some challenges right now.