Grid lines on photo

Why is lightburn adding gid lines to my work?

Version 0.8.07

Please also show the original image and the workspace with your Cut Settings visible.

BTW, LightBurn has released 9.02 so you are not using the most recent release. We recommend running the most recent releases as there are fixes provided for issues raised with previous versions.

No problem.

The latest version show some form of gridding on the preview too.

version 9,02

This may be a moire effect happening here. Was this image dithered outside LightBurn? This will happen when LightBurn tries to dither an already dithered image. If you want to use another program to process your image prior to importation into LightBurn, select the ‘Pass-through’ option in the cut settings. This tells LightBurn to not do any image processing and send the file without touching it, using the DPI set in the externally processed file.

yeah problem is if i dont set it to grey scale the image does not come out good at all. Wonder if it will be ok if i set lasermode in GRBL to 0 rather than one and then select pass through.

No settings pass through ruins the engrave and setting grbl to laser mode off just burns through the wood.

Not sure why you are suggesting turning grbl Laser Mode to OFF.

If this image was dithered outside LightBurn, setting ‘Pass-through’ to ON will force no further image processing and avoid any potential moire effect from happening. With ‘Pass-through’ turned OFF, LightBurn will process the image based on the Image Mode selected. Doing so to a pre-dithered image will create odd image results from running multiple dither processes on the same image. Dithering a dithered image is not good, and can cause the effects you are seeing.

i know what you are saying but it and in theory that should work.

Look at this example below. Same focal point same power settings same material.

this one image processed with pass through enabled:

the same image but using greyscale in LB

makes no sense to me. I suggested laser mode off as most lasers such as diodes are normally set this way.

If you’re dithering outside of LightBurn you will get moire artifacts if you don’t use the pass-through option, period, always. LightBurn was made to do its own photo processing, and so it automatically resamples images to exactly match the output size at the DPI you specify. Dithered images do not resample well.

The fact that it doesn’t work unless you enable grayscale is bizarre - the commands used to emit a photo with grayscale mode are identical to those used for dithering / pass through, so I’m assuming you have an incorrect setting somewhere.

Start with this one: what’s your $30 value set to in GRBL, and what is the value of “S Value Max” in the device settings in LightBurn? (They have to match)

Turning off Laser Mode will just make your machine stop every time there’s a spindle speed change, so you absolutely don’t want that.

here is my config:




































LB setting


Short vids:

I don’t see anything there that suggests what the issue could be. Can you create a postage-stamp sized picture and save the GCode from it with the same settings? One with pass-through enabled, and the other as grayscale? You can email the gcode to developer at lightburnsoftware dot com and I’ll have a look.

email on the way thank you