Grinding Stepper Noise with No Movement - *Solved!*

Hey guys, my machine has done this grinding noise occasionally, but a reset clears it right up. It’s not physical grinding, it’s like the steppers have no power and simply skip steps instead of moving the gantry. Since Monday, nothing I do will stop this. It’s very strange, as if I move X or Y independently, it makes no noise. If I move the 2 in tandem, all sorts of steps are lost on both X and Y. No pulleys or belts are slipping, and if I try to stop either axis with my hand, I cannot. It’s strong. I checked both the 24 and 48v power supplies, and there’s not so much as a dip when the motors move. It’s only when the file starts, or you move 2 axis at once. It immediately skips steps. Any idea?? Thanks so much for any input you can give.

I’d post a video, but the dang forum doesn’t seem to have the option to do so, without first uploading it to YouTube or something like that. So I guess I’ll go try to do that and come back and do a follow up post.

Ruida controller, Nema 23 steppers.

Video here:!Aq-dl-TSBdBMo2y2f5J23ylSBLKS?e=Jnwxyg

Hi there
I had similar noises with my laser. It was due to the connectors from the power amplifiers to the stepper motors. There was a small piece of plastic between the plug and socket. it fell into it while stripping a cable. as a result, no real contact was possible. check the connectors whether they are in the right contact. good luck

I figured it out… My employee had entered the “speed” menu on the Ruida touchpad, and set it to 2000, because he thought the table ran to slow when he manually jogged it between sheets…

Then, The file I’ve been cutting for the past 2 1/2 weeks had 2000 set as the speed for a low power line cut (text)… the machine cannot go that fast… So basically, the steppers were just stalling out… I found a post from 2003, and that was the same problem they were having… and Hot Dog! That was it…

A simple matter of over speed. I guess the reason I’ve had it happening periodically, is that he’s been setting the speed back to 2000, though I usually reduce it again to a slower more accurate speed for setting the origin. I thought the machine was doing it! lol

If you start the movement at either end of the 5x10 bed, it doesn’t skip, until it hits the center of the bed. I’m going to chalk that up to misalignment of linear rails, or something of the sort. Something offering Just enough “push back” to cause it to stall.

To confirm my Hypothesis, I set it back, and brought the problem back… Changed it back to 400 speed on the controller, and all was fine!

Mark this case Solved!!!

If you go to Edit > Machine Settings you should be able to set a maximum speed for each axis there that’s realistic, that could prevent this issue in the future. Glad you figured it out!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.