GUI resets after exit

Very annoying, and I don’t understand how this bug is still present in the software as of 2023… The GUI where camera is located is absolutely resets all the time you relaunch the software. It is probably due to camera being initiated a little later, but this is fixable with proper coding and should be. Super annoying to have to resize the camera area every time you launch a software. Over all this should not be sold for profit, it’s a beta with many bugs and it needs 1000 refinements to make it a useable software, GUI is a mess, on high DPI large screens at least. Metric area is unfinished, many things are incorrect. text settings for material test arent working at all, totally ignored by the software. etc etc etc etc etc.

I find it funny how developers do not even have the section on a forum for bugs, talks a lot about the arrogance and ignorance. Because this software absolutely begs for that. Poorest coding I have ever seen in my life in $120 software. If you don’t see things yourself, at least use community to help you maybe.

1 Like

Bugs are generally submitted by email or here, and we do take them seriously.

For the UI scaling issue, that’s a result of the cross-platform framework LightBurn is built on, and we don’t have direct control over that code. There’s an easy fix though - follow the steps on this post: Device Settings dialog messed up in 1.1.01 - #3 by LightBurn

Text settings for the material test work as expected for me. What kind of controller are you using? (your profile lists “123” which tells me nothing). If you click the blue ‘Edit Text Setting’ button in the Material Test window and change that to Fill, that doesn’t work?

Finally, you might be familiar with the phrase “you catch more flies with honey”. Your tone needs work. I’m happy to engage with you about shortcomings in the software, but I’ll expect you to at least try to be civil.


Fair enough about the honey! Ruida. Thanks, I’ll try that compatibility mode then. I have a 42 inch screen, 4k. Yes, it does change to fill, however it does not allow to fill them all in once. Well, technically it does, but it ignores that setting. Despite of what you set there it would still fill each letter separately and needless to say, its a huge waste of work time. It’s painful to run that script just for that fact alone. While I am on it, GUI also keeps resetting, how is it possible to have the software out for years and still have that, is beyond me. The right pane where move, cut layers and camera is located absolutely resets not only when you close the app, but also when you even try to move or resize the window. I have seen another user report that almost two years ago by the way. Software feels like every single thing was copied from RDworks, including all their shortcomings too, plus additional bugs. I dont use this software for designing, I have corel, and I even exactly picked the colors while exporting and importing and lightburn still would not understand the color correctly to match it with internal process color. I don’t know guys, is there even a point of reporting this if you don’t fix even small things for years? I am not gonna get into loads of more sophisticated problems within the software, but at least the GUI needs to be sorted out. So far, for a corel pro user, the only one single difference I see with free rdworks is ability to comfortably rotate object by dragging. I am still on trial, and this one feature doesn’t justify $120 high license cost to me. $60 is more reasonable, but I am not sure what made you justify double price for Ruida controllers, which are just as popular in hobbyist area, they are not really business controllers either. Business and personal licence would make some sense, not sure why it is attached to controller type instead, unless it needed significantly more coding. Which again, I am not sure if you have done it, as it feels like forked RDWorks to me with some GUI refinements and better english tags.

Oh and almost forgot, sometimes it fails to send the file over, and it results in machine starting to burn partial file. This is a very serious bug if you ask me, you need to implement a successful file transfer check before the machine fires. I am on LAN now for that reason, when I was on WAN using $10 apple airport express it was way worse as software doesnt have any proper protocols, it jsut blindly transfers hoping for the best. And packets do get lost sometimes, way less with cable connection now, but happened yesterday to me, $20 worth of material wasted. Coincidentally this is a problem carried out from RDWorks as well.

Also not too sure why you guys chose a cross platform, do you really have people who needs to absolutely connect a mac to laser? I mean, we aren’t editing videos here lol. My guess would be that maybe its 3% of your audience, but probably less. But now you have to deal with all those GUI problems due to that, as far as I understand.

Can you elaborate on this? I don’t see this behavior myself - if you could record a video and post it somewhere, or just post some screen caps to show what you mean? LightBurn’s window layout is recorded per-laser, stored when you quit and restored when you restart.

Regarding the material test not respecting the fill settings, which version of LightBurn are you using? The current release (1.3.01) works exactly as it should for me. The material test wizard was originally for galvo lasers, and ported to work with all others, so there were a few settings that were “held over” for a version or two, one of those being the individual lettering, but that’s been fixed for a while. (the code change was made on Sept 30th of last year)


Because it took about 4 months of reverse engineering to figure out the command set and reproduce it reliably, compared to GRBL / Smoothieware which are open source and fully documented.

It isn’t - it was coded from scratch, by me until about two years ago, because I wanted the functionality of RDWorks with better usability. I imitated the layout of RDWorks, and anything I felt they did decently.

If you’re only using it as a receiver for Corel data you won’t notice a massive amount of difference, but if you start actually using LightBurn for anything else, you’ll see it pretty quickly. Things like automatic welding of text, ability to use sub-layers, a far better image trace tool, hotkeys for everything, unlimited undo / redo, drag & drop support, etc, etc. RDWorks has improved a decent amount since LightBurn started, partly as a result of pressure from LightBurn’s existence.

LightBurn’s preview gives more accurate times, and the generated cut files typically run in less time (if you’re doing more than just simple engraving, at least) because our path planning is smarter. It also takes a LOT less time to generate those paths - sometimes a few seconds compared to minutes, if your files are complex enough.


It’s not just for cross platform compatibility - it also provides a decent amount of infrastructure for graphics rendering, controls and window layout, container objects, language translation (localization), network and serial port access helpers, and tons more.


Your guess would be wrong by about a factor of 5. Just shy of 16% of our users are on MacOS, and the number has been slowly increasing.


This is a shortcoming of the Ruida hardware, and not something we can do anything about unfortunately. The Ruida controller assumes perfect transfers, doesn’t even use checksums over USB, and uses UDP transfers for network, with a very simple checksum and no mechanism for retry. They’re made to be hard-wired, and I have no control over the protocol itself. This is why it also happens with RDWorks.

See above. Since the Ruida uses UDP, any interference or packet loss will result in a transfer failure. We created the LightBurn Bridge to address this exact problem - it uses TCP to communicate from the PC to the bridge, then a wired network connection from the bridge to the controller, so the connection is much more stable. If you have a compatible Pi laying around, the image files to make your own are free to download from our site.


I am on 1.2 something, I downloaded it several moths ago I think. I will try 1.3 then. Didn’t know there were some significant updates. As for GUI resetting, I am on windows 11 btw, I am not sure how else to describe that, every time window is sized down or application is restarted camera section starts with tiny camera view, no matter what size was set before.

Thanks for other answers, Ruida by itself is a very poorly made basic controller, too bad in 2022 we dont really have better options and small businesses are simply incapable of developing something better due to R&D costs. Ruida company got was too lazy and relaxed and their controllers are truly 1970s, I am not even surprised they don’t have a proper checksum. Oh well. By your experience is there anything significantly superior on Ruida controller vs say Smoothie or reprap or whatever. Just one fact alone that they are not opensource code should already place them behind the competition, but for some reason they are widely popular, including my laser machine too. And it is not just the absense of basic checksum, my machine actually starts burning immediately once transfer is STARTED, transfer may take around say 10-15 seconds for large files and machine starts burning immediately, without even waiting until the whole file is received. That makes no sense to me at all.

Also just today experienced the same problem, there is something wrong with layers I believe, again I was unable to select inside text when I grouped it. It seems like you guys do have z layers implemented, but for some reason they don’t work.

Also coming from professional vector software, its a HUGE problem in lightburn that you guys made copy paste the way you made it. ( I get it that many users wont notice it, as magority have nothing to compare with in vector area) I totally hated RDworks for that silly method, and I guess you just copied it as you said, but its hell awful. Let me try to describe: when you cut an object (CTRL+X) and then paste it, instead of logically inserting where it was originally located, it inserts at mouse cursor position. This functionality makes absolutely zero sense and it takes away very important abilities to work with vector graphics layers. I have over 15 years of professional experience working with vectors, just FIY. And cut and paste feature is very important and it should be implemented correctly. During workflow I always use that to remove the object into a buffer so to speak, while it is removed, it makes it easier to select other objects around for example, and do any other manipulations around it, then a simple CTR+V returns the object into it’s place. This is a very easy feature to even add to your settings, so users can at least choose. Again, coming from pro area, I find it really useless to insert at mouse location, this does not offer any accurate positioning and is only good for kids projects where no accuracy is needed at all. And as I mentioned already I believe, it needs more work IMHO with how vectors are selected, today I have already experienced unsolvable problem of impossible selection in a middle, trying to move Z layers does nothing. (like CTRL+HOME for example). For example why in the world does it select an object that is literally a hole, an empty area? I am trying to select an actually filled object and the software fails to understand that, it keeps selecting empty outline while not letting me select an actual filled object. Some additional vector functions are cool, but you guys are laser controller software, and I think those problems should at least have a priority first. This particular problem is not at all present in rdworks, rdworks understands graphics much better actually. I have no idea what simple rectangles users are burning, but working with complex geometries is a nightmare to be honest, I have never wasted that much time to do a dead simple thing like solve an impossible selection of object. I literally had to close the file and start from scratch, and carefully do things in order to not get stuck in unsolvable area again.

Granted corel is very expensive and you are right I do not judge based on that value, as I have corel already and its way more functional and capable hands down which also it better be. From Lightburn I expect to be a laser software first and vector second. Being such a small team I can imagine that it is actually much harder to implement new vector features vs laser burning functionality. Same was CAD is much harder than CAM to program.

I will try and talk to Ruida about those problems with the board, will see what they comment on that.

I think I may have some understanding of what is going on with Z layers, they are BACKWARDS. I was using pageup obviously and logically to bring the object to front for priority selection and it is backwards, now I tried pagedown instead and it seems to bring the object to a front. Is this actually true? I mean this is counter intuitive and also seems to contradict with your own menu sections. Also you guys should not take examples from horrible chinese software when programming yours, especially concerning vector functionalities. Check how corel or adobe illustrator does it instead, way better examples. Also another good idea is how corel does layers - when holding ALT button in corel you can select through layers one by one by clicking mouse in the same area, thats also very useful when working with multiple layers. Context menu should also have “bring to front” fucntion easily accessible. All these isnt hard to add, so I feel like I should mention this.

No it isn’t backwards either, it just works sometimes and sometimes it does absolutely nothing both ways. There is some bloody mess going on in backend probably. I worked with logo inside honeycomb pattern, if you are curious what it was, and I did same thing 3 times and all 3 times results were unpredictable of how things were being selected. Maybe double check if Z layers work on grouped objects or not, just a thought.

Played with it some more, two problems: they are indeed backwards and they do nothing to grouped objects at all.

Also remembered something else, duplicating. This is just a feature suggestion. When you click CTRL+D it duplicates, then you move the duplicated variant, lets say, 10mm down and 10mm to the right. Vector software in this case, if you click CTRL+D again, will remember the previous modification and will duplicate again, but this time it will already position it as X+10;Y+10. And if you click duplicate many times, you get a nice pattern. Corel does this and it is a huge time saver. Doesn’t seem hard to program as well.

Over the course of many decades on both sides of the discussions, I’ve learned the hard truth of Weller’s observation:

Nothing is impossible for the man who doesn’t have to do it himself.

Ctrl+D (as you’ve found) is duplicate, and there’s also Alt+V for paste-in-place, so you can Ctrl+X to remove something, then Alt+V to paste it back to exactly where it was before.

Regarding the issues you’re having with selection and front/back layering, I suspect you’re using ‘Filled Rendering’ mode, which we don’t recommend for anything but spot checking. The way LightBurn handles filling is just everything on a layer with an odd/even fill rule. If you click inside a filled object, it grabs the outermost vector. When using wire mode, you click the actual border of a shape to select it and things are much more intuitive this way.

It’s not a paint program, so if you have a red fill overlapping a blue fill, for example, they’ll both be sent to the laser, and the overlapping area will burn twice, and using Filled Rendering hides this, along with making things like selection and node editing more complicated. If you get used to working in wire mode, it’s faster and makes a lot more sense in general.

For file transfers, if you hold Shift and click the ‘Send’ button instead of clicking ‘Start’, the file is named and sent to the machine in its entirety, and if the send works, the job is automatically started. This is close to the convenience of the ‘Start’ button, but with a little more security. You just have to remember to periodically wipe the file memory.

We update often. You can see what’s been done with each update here:

I majored in Computer security, so one could imagine I know a thing or two about coding. And I do so much myself for the market, you wont believe how much actually. While your saying is generally correct, it doesn’t apply here at all.

Thanks a lot for taking a time and pointing me in the right direction as far as features are concerned, this all will definitely make a workflow much smoother for me. I honestly have not even seen that there was a wireframe view mode over there, I do prefer filled though, as it gives a better understanding of how the object would look burned, but that’s very good to know especially for selection problems situations. Have you had a chance to check PGdown PGup funtionality? Isn’t it backwards? In my understanding pgup is supposed to bring the object to the top, right? Well, at least knowing that layers do not work for grouped objects and that they are reversed already helped me a lot haha. I kept clicking pgup and it would do the opposite thing. Definitely trying Shift+send next time too! My jobs are generally 1-2 hours long, so a lot of material is involved.

Thanks again, I now can relate why my friends all told me about your exceptional customer service and product support :slight_smile:

Alt+Shift+W (toggle wire / filled) is your friend. Like I said, I’ll use it for spot checking or screen shots, but for seeing what the end result should look like you should be using the preview (Alt+P).

The preview shows the complete path the laser will take (and will optionally show travel moves and provide a time estimate), so you can see whether you’re wasting a lot of time on extra travel, might hit a clamp, cutting order matches what you expect, etc.

PgUp / PgDn alters the order of the shapes in the internal shape list, which in turn affects the the drawing order in wire mode only, and should affect the selection order, but when using Filled Rendering, shapes are drawn in layer order, period, and there’s some interaction with the layer order and selection as well if I’m not mistaken.

It’s not intended to work like a traditional paint program, and you can do strange things like put two objects on the same layer, but in different groups. For example, in the image below, the two squares are one group, and the two circles are another:


Now, if I view them in Filled mode, and click the filled area of the right (black) shape, what should be selected?

There’s no right answer there, so we’ve kind of punted and assumed that you will group your shapes in sane ways if you’re using Filled mode, but this is the kind of thing that can (and surprisingly often does) happen.

1 Like

And PgDn / PgUp behavior is easier to see with images. This is me pressing PgDn twice on the right-most rhino, then again once on the middle one:


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.