Guidance for SVG fill - stopping it from crossing a line?

So I am trying to laser engrave my logo from an svg-file to be able to get thicker lines than just doing it from a .png.

Since there is a gap in my logo I don’t want it to engrave that area. How can I make it so that Lightburn doesn’t fill the area in the middle? If I set it to fill it will fill the inner shape as well. If I separate the two shapes and set the inner shape to line it still fills it when doing the outer shape.

This is the logo:

This is the svg:

You most likely have either duplicate lines, or a gap. Below is 3 scenarios.

So what you are saying is that if I don’t have a gap in the design, because I know I don’t, there are duplicate lines? So at normal it should work by setting it to fill and it shouldn’t fill the space in the top of the logo? =)

Can you make a screen shot of what your file looks like when fill rendering is turned on?
image

If you don’t have double lines or a gap, it should look like this with fill rendering turned on.
image

Here is how my file looks like before importing and setting to fill - the same as what your 2nd screenshot
image

When you zoom into your screenshot, I also see green lines behind the dashed black lines. When I set my colors to black and zoom in, I don’t see green lines. Here is your screenshot zoomed in

My filled rendering looks like yours. I will have a go again to make sure I didn’t do anything wrong the last time. Thanks for showing me the rendering setting.

I’ll take a picture of the complete engrave and post.

Thanks for taking the time!

You can always try to delete duplicates using this command.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.