Gweike G2 Fiber Laser Not Connecting on M1 Mac

Lightburn not connecting to G2 Fiber laser on M1 Mac. I have connected it Manually and selected the sea cad file. Is there any thing else i have to change. Using LightBurn 1.7

I don’t know where you find your usb device information on a Mac…

That’s the best place to start, ensure the os can see the device… If the os can’t see it, Lightburn can’t connect to it…

Are you in the beta group?

I run the consumer version and the beta test version… both are installed.

If you can, I’d suggest loading, what was a working version and see if it is indeed a version issue. I kind of doubt it… but you never know.

Check that the os can see it first.

:smile_cat:

Bonjour, Meme problème avec le G2 Gweike, Lightburn 1.7 et Mac ? j’ai 2 Macbook, un de 2012 system intel avec osx Monterey et un de 2023 system M2 osx Sonoma la licence Galvo est activé sur Lightburn mais pourtant rien ne fonctionne ni sur intel ni sur M2 le laser est pourtant reconnue sur l’USB du Mac.

I`m a TI99-4A, C64, Amiga, Spectrum, Dos, 95… not a Mac nor a Galvo guy :slightly_smiling_face:

I may be wrong, but let’s try my line of thinking

After asking in Gweike’s chat if the G2 worked with Lightburn the answer was yes, if it worked with Windows or Mac the answer was none.

Questions:

  • Was the G2 recognized before the GLaser software was installed?
  • Can you check if the drivers GLaser uses are FTDI?

If so, copy the settings and uninstall GLaser. This means that it has been recognized with the Mac OS drivers, as Windows use FTDI lightburn (1).zip.txt (3.2 MB)
drivers…let’s try install FTDI drivers for your OS/(G2 serial) but with a workaround.

Regarding this link this link and as it seems newer macs automatically block the FTDI serial connection from being used as a com port and also check FTDI drivers for Mac

facebook group
Review and some settings

None of the suggestion work I have installed the both FTDI and CH341 driver yet no change. Under system repost I can see device connected as sea laser.

Pareil pour moi aucune des suggestions ne fonctionne. J’ai installé les pilotes FTDI, mais aucun changement.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.