Hard limit error

hello i have a atomstack p7 m40 40w portable laser engraver. i am trying to once again figure out why i am still getting a hard limit error if the hard limit and soft limit are disabled. trying to engrave an image. i have tried decreasing speed started at 1000 all the way down too 700 so far and i am still getting this error. i have also decreased power from 70 all the way down to 10% and i cant figure out whats going on. it should not be this hard can anyone please help!!

How have you disabled these?

Power and speed settings should have no bearing on going out of bounds.

Can you send a full screenshot of LightBurn with the Laser window showing please?

here is a screen shot, it also has the image i am trying to engrave yes when i pull up my codes it says soft limit ($20=0, hard limit $21=0) i dont know what could be the problem i have been trying to figure this out for almost a week

from previous research i was informed that if both hard limit and soft limit were at 0 they were disabled

I didn’t think Atomstack allowed permanent changes to the GRBL configuration. Are you setting those each time you start the laser?

Also, what happens when you get the error, are you crashing into the frame?

Can you confirm if your laser has homing switches and goes through a homing cycle when powered on?

If you’re just starting up, you should limit yourself to using “Absolute Coords” in the “Start From:” pulldown in the Laser window.

It’s the most intuitive way of using your laser. Whatever you see on screen is where it will burn in relation to your bed.

You can read more about it here:
Coordinates and Job Origin - LightBurn Software Documentation

Try Absolute Coords and see if that changes what you’re getting. Please report back.

no it does not crash into the frame although when i hit the home button it definitely crashes into the frame so i stopped doing that because i dont want to damage my machine

trying in absolute coords now got the same error!

this is what happens when i go to home…

So I’ll take this to mean that you don’t have homing switches.

This is probably going to come down to your startup process.

  1. While machine is off manually move the head of the laser to the front-left of the machine.
  2. Startup the machine.
  3. Check “Get Position” in Move window. Can you confirm the coordinates there?
  4. Assuming it’s 0,0 try a test burn.

ok i moved the laser head manually with it off turned it back on now position is 0,0

still same hard limit error

Can you copy the error here?

That’s now starting to not make sense.

Can you go through these steps to gather some additional data please?

  1. Restart laser with head at front left. Then run these commands in the Console window. Copy and paste back the results.
  1. Using jogging controls to move laser to top left. Then type ? in console. Return results.
  2. Repeat above for top right.
  3. Repeat above for front right.

top left:<Idle|MPos:190.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>
front right:<Idle|MPos:190.000,190.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>
top right:<Idle|MPos:-10.000,190.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>

front right: please ignore the other <Idle|MPos:140.000,190.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>

Do you or do you not have homing switches?

You have homing enabled, which require homing switches or you get an alarm 1

I didn’t think you could get a ‘hard limit’ error with that option turned off.


Is this what you’re describing in terms of the coordinates?

Can take a photo of the laser as you have it setup please?

here is the picture of my laser

me either but for some reason i still am and its a bit flustering because i dont know what else to try

side note!! i only have this issue when trying to fill (engrave) when i do like lines it works just fine