Hard limit triggered issue

I’m gettiing this message and my laser is showing “busy” after I HOME the laser after I run a job.
Alarm:1
Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

Not sure what to do to fix this.

After your laser homes, is it pulling away from the homing position, or resting on the limit switches? If it’s resting on the switches, you may need to increase the homing pull-off distance setting in your laser’s firmware. You can check on and adjust that distance by going to ‘Edit’ > ‘Machine Settings’ in LightBurn.

You can also do that through the Console window in LightBurn. It’s the $27 value - you can check on its current value by entering ‘$$’ in the Console window, and edit it by entering '$27=(new value).

If you share the values you see when you enter $$ in the Console window, we can let you know if everything looks relatively normal.

If it is pulling off, but you’re still seeing the Hard Limit Alarm message, that suggests a hardware failure of some kind. Make sure the limit switches are wired properly, and not getting stuck in the engaged position.

It is showing a value of 2. I changed to 3 (because I wasn’t sure what value to put) and I have the same issue.

Are you seeing it pull away at all after homing? Do the limit switches appear stuck?

Which laser do you have exactly? Homing itself works fine? Did you enter the correct workspace sizes in LightBurn and the firmware?

As soon as the job finished it when to bottom left corner. Now it says “busy”.
I didn’t HOME it since it was “busy”. It seems like the limit switches are barely touching the laser head.
Sometimes it seems to bounce back at returning to the corner but I didn’t see it happen this time.

I have a Sculpfun S30 Pro Max. I think I set the correct size…let me check.

Where can I check the workspace size?

Ah, check the device settings window in LightBurn. Did you activate “return to finish position” and entered 0,0? Try changing this to 10,10. Then it will stop in a secure distance to the switches.

You can check in the device settings window what value you saved in LightBurn and can check the machine settings to get the firmware output. Usually, there is something like 400×410 entered, but the Pro Max only has 370×360 usable workspace.
Here is some guidance on setup: Setting up the software - Diode Laser Wiki

I had initially setup the laser manually since the device couldn’t be found. Today the device could be found so I set it up that way. Hopefully this will fix my issues.
Thanks for everyone’s help!