Having a nightmare with homing and limit switches

hi all I’m new to this forum and to cnc machines

using grbl

i have the sainsmart prover and 5.5w laser module (prover)

the issues i have is with homing and work area firstly
homing

whenever i click homing my x and y go really quick to the top left corner and don’t stop until they have hit a limit switch i have change the origins og the laser to all 4 sides and it always go to the same side until it hits limit switches. i have done successful runs but this has been using the "start from current position setting this seems to be the only way i can do it at the moment

also when i use the "set laser position " that also fires the x and y off to the same side with no control and full speed until i either hit stop or hit limit switch

2nd issue

the work area seems to be off which again i cant figure out why i have it set as x 300 y 180,
i needed to do a project to the exacts measurements if 300 x 180 wood is bang on in sizes but it hit a limit switch about 20mm away from the end of the wood is my plate off Centre?
the measurements on screen are noting like im getting in real life i draw a box bottom left corner the actual burn will happen somewhere in the middle cant seem to get a accurate result

also it just hit a limit switch so hard the lever fell off lol brilliant

thanks for any help in advance

How is this different than what you expect to happen? How many limit switches do you have and where are they located?

In a normal CNC homing operation the head would move toward the homing switches, first toward Z switch, then toward XY switches. After first contact the switch would back off a little and then reengage switches at a slower speed and then back-off just a bit and come to a stop. Is this what is happening with you? If so, then this is expected behavior.

I believe origin on the Sainsmart Prover should be set to front left but may not be correct. Can you set the origin to front left and then do the following?

Run a homing cycle and then immediately following that run these commands in Console window. Run them one at a time. Then copy all the results from the output window in a response:

$I
$$
$#
?

Also, confirm if the jogging controls work as you expect. Left goes left, right goes right, up goes up, down goes down, Z-up goes up, Z-down goes down.

1 Like

hi and sorry for lack of information its hard to get my head around all this

so when i press home button underneath the frame button and the home button on the jog/move green bar says busy then in console this error comes up

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases

noting actually happens

not sure if i need to mention this but i have my z axis cable removed as i am at the right height for focus now

movements right and left are ok but up pulls the bed down and down goes up

not sure if you wanted the consoles codes although homing didnt work

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

$I

[VER:1.1f.20170801:]

[OPT:V,15,128]

Target buffer size found

ok

$$

$0=10

$1=25

$2=0

$3=2

$4=0

$5=0

$6=0

$10=3

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=3

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=10000

$31=0

$32=1

$100=800.000

$101=800.000

$102=800.000

$110=2000.000

$111=2000.000

$112=600.000

$120=10.000

$121=10.000

$122=10.000

$130=500.000

$131=400.000

$132=100.000

ok

$#

[G54:-231.000,-231.000,-87.367]

[G55:-2147483.648,2147483.648,2147483.648]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|MPos:-5.000,22.466,150.000|Bf:15,127|FS:0,0|WCO:-231.000,-231.000,-87.367>

ok

Had you disconnected Z motor after your initial post or did I misunderstand your original situation. I’m trying to figure out if the previous data still needs to be considered in some way.

You won’t be able to home if this is the situation. GRBL is timing out because it’s trying to home the Z but isn’t getting a limit switch triggered within a specified time. You can choose to not home as there are alternative ways of working. Or you’ll need a different or custom version of firmware that excludes Z from homing.

If I understand you correctly this should be okay. From the perspective of the laser head, relative movement is up as bed is going down and vice versa.

This enables homing. Disable this by issuing $22=0 in Console or reenable Z-motor and sort out homing.

You have 2 different work offsets created. Do you know if these were deliberate and their purpose?

What was the position of the laser when you ran this command?

Normally in systems without homing switches your startup process would require you start the machine with the laser head at front left. This becomes 0,0.

Can you move the laser head to front left of bed, power cycle, then rerun ? and return results?

right ok ill put the z cable back in and give it a go

z motor has always been unplugged as i don’t want it to mess up my focus

mate I’m really grateful for the help massively thank you

Happy I can help.

One advantage of having this enabled is that you can potentially have LightBurn handle material thickness and it will adjust focus for you. You can also have LightBurn move focus down as you cut through thick material.

It’s not essential for what you’re doing but you’ll just need to work in a different way in your particular setup.

hi mate cable in and homed correctly excellent thank you it is still going top left although settings say bottom left

also absolute coordinates is still mess up see attached document i put this box here and it shot off over to other side both y and x until i hit limit switch

thanks for all your help you need a medal

Homing location is not necessarily the same as machine origin. I’m not certain but I’m pretty sure your machine origin is meant to be front left. Can you go to Device Settings and set Origin to the bottom-left (front-left)?

Then run a homing cycle and then do the following:

  1. Type ? in Console. Capture the output.
  2. Move to back-right corner. Type ? in Console. Capture the output.
  3. Move to front-right corner. Type ? in Console. Capture the output.
  4. Move to front-left corner. Type ? in Console. Capture the output.

Just want to see how the coordinates are coming out. I suspect you’ll need to remove the offsets that are currently configured.

  1. ok
    ?
    <Idle|MPos:-499.000,-399.000,-1.000|Bf:15,127|FS:0,0|WCO:-231.000,-231.000,-87.367>
    ok
    2.?
    <Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|WCO:-231.000,-231.000,-87.367>
    ok
    3.[VER:1.1f.20170801:]
    [OPT:V,15,128]
    Target buffer size found
    ok
    ?
    <Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|WCO:-231.000,-231.000,-87.367>
    ok
    4.VER:1.1f.20170801:]
    [OPT:V,15,128]
    Target buffer size found
    ok
    ?
    <Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|WCO:-231.000,-231.000,-87.367>
    ok

Hope this is what you mean you guys are geniuses understanding all this

also i hit homing on every selection front right rear left etc still went to same location and yes i do believe it should home to bottom left

Thank for going through this. Actually, I didn’t want you to home at every step.

Just home once. Then go through the following:

  1. Type ? in Console. Capture the output.
  2. Move to back-right corner. Type ? in Console. Capture the output.
  3. Move to front-right corner. Type ? in Console. Capture the output.
  4. Move to front-left corner. Type ? in Console. Capture the output.

What I’m trying to see is what the machine position is at each corner. That will help me establish where your origin is actually intended to be.

Can you send a screenshot of your Device Settings as well please?

hi mate i didnt press home at every one of those just change homing and typed ?

not sure if this means anything but just changed it to bottom left to take a screen shot and now the writing i have there has gone upside down

Ok. I misunderstood what you meant in the last sentence. Also the numbers look odd.

How did you move the laser head? Did you use the jogging controls or the controls within LB? Or did you move by hand? This would need to be done through LightBurn controls or else the steps will be lost.

Any design done using a different origin setting will need to be adapted. I’m not certain as yet what your origin should be. I’m pretty sure it’s front-left but I’m hoping the coordinates test I’m asking for will answer that.

its like the software doesnt know were my machine is

i tried to use set laser position it fire off to bottom right but on the screen it says its only 100mm across

hi mate moved it with jogging on LB i only do it by hand when hit limit switches

This is because of your offset as well as using Current Position in Start From. Once we sort out your origin I’ll help you sort out the offsets so that you can work with absolute coords or current position.

Hmm… That’s super odd. The last 3 results were all the same. Can you try it again but don’t go to the full extreme corners. Leave several mm from each corner.

sorry buddy getting a bit confused here what do you want me try again?