Having issues saving projects after updating to 1.0.04

Went through the normal update as it asks during every start. Since I updated I have can not get Lightburn to save a project. Maybe once in 10 attempts it will save the project but I’ve made sure my destinations have no restrictions and I’m not getting anywhere solo. Any suggestion?

It asked to update to the newest version each time you open the program. So I finally updated, now I cannot save projects. I will try to save the project multiple times, once in awhile it will save the project but for the most part it does not save projects.

How are you confirming this? Tell us exactly the steps you take, so we can try to reproduce here. We have not seen this reported before. What happens, technically, when you try to save the project. What is reported from LightBurn or your OS when you try this?

I’ve also noticed this (LB not saving) but I think it might have also been present in earlier version(s) and not just 1.0.04. I first noticed it when I tried to export some graphics and nothing was exported, so I tried again and the second time it exported as expected. There was no error or indication that the export failed. Unfortunately I can’t remember which particular file I was trying to export now but I don’t think that’s relevant.
However I’ve also noticed that this not only affects exporting but also the saving of the actual LightBurn file. I’ve just tested it and sometimes it will save as expected and other times it doesn’t. Again, there’s no error and no indication that it hasn’t saved other than the application title bar still says ’<untitled> *’. If you then try to save the same file again it brings up the save dialogue (as it does the first time you save something). Sometimes this will succeed (the title bar shows the filename) and subsequent saves don’t then invoke the save dialogue (as per normal behaviour). I haven’t observed whether subsequent saves of a successfully saved file fail or whether it’s just the initial save that it has problems with.

Anyway, I hope you can make sense of all that! I’ll try to put together a video which demonstrates the issue. I’ll also do some more testing and see whether I can get any clues by using Sysinternals Process Monitor.

BTW, I’m on Win10.

Thank you for this further detail. Please do provide what you find with your investigations. :slight_smile:

As mentioned, we haven’t seen this reported before. We did have a user a while ago whose anti-virus software kept deleting LB files after he saved. In this case, the user was able to see the files on the “Recents” list, both in LB and in Windows, hinting that it had saved, or thought it did. He actually had to uninstall the AV software to make it stop doing this.

Do you have any AV / Malware software that could be blocking or removing these saves?

Yes I do have anti-virus installed (as everyone should!), currently I use Avast, I also use Acronis for system backups and they’ve recently added AV to the software. However, I don’t think the issue is that LB is saving files and the AV is removing them, otherwise it would happen to all LB files I save. This seems random and intermittent. Not forgetting that as I said the LB title bar still says ’<untitled> *’ after a failed save so even LB is aware that it hasn’t saved. It’s not a show-stopper but I do need to be vigilant and check that it’s actually saved.

So from the start, I will open LB. Create a project, click file, scroll down to “save as” find the folder I want it to go. Name the project, hit save and the popup box goes away as it would normally when I hit save. I will notice the header for LB still says untitled afterwards. I will open explorer folder and search for the folder outside of LB and file that I saved will not be there. Now a second attempt was made closing LB down and stopping all processes. Open LB-create new project- then in the header of LB clicking the X to close the program prompting the popup/auto save feature to come up asking me to save the project before I close LB. Select folder-name project-click save…popup window goes away, nothing is saved, LB header still says untitled…no file to be found outside of LB.
Once in a great moon the file will save but I do nothing different. Luckily all the projects I have been using it for as created outside of LB so when I import them they are already to scale and I just need to adjust settings.

I do not run any antivirus software other then Windows 10 default. No issues with LB files disappearing either just can’t save projects once I make them inside of LB.

Nothing is reported from LB or my OS. Forgot to mention running WIN 10 on a new MSI ROG laptop, no issues with resource or memory management. I have used LB on this laptop for a few months now with only user errors till this last update.

Try this:

  • browse to the C:\Program Files\LightBurn folder
  • locate the file called LBFileDialog.exe
  • rename it to something else (just add .bak to the name, or whatever you like)
  • try saving again, and let me know if that behaves any better

Beautiful that did the trick, very much appreciate the help and quick response.

Thanks, I’ll try that too but unlike @Damello mine doesn’t fail so frequently. So out of curiosity: What does LBFileDialog.exe do if we’re able to rename it without breaking LB?

I’ve been told, LBFileDialog is a sub-app - it’s a small application that shows the file chooser and returns the name you picked. That’s it. The reason is that if you have a thumbnail previewer that crashes, it only takes the little file chooser app down, not LightBurn. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.