Having laser issues


(Kylie) #1

I have a 3018 cnc with a 5500mw laser and am unable to get the laser to fire, it has a small board between the main board and the laser, it doesn’t have command $30,$31 or $32 in the GBRL control so cant change that, had it going on another program so it must have a dedicated laser circuit but not sure how to get Lightburn to control it.

any ideas appreciated


(Oz) #2

Try using the GRBL-M3 device in LightBurn instead. If the controller doesn’t have $30 to $32 in the settings it means it’s an old version of GRBL.


(Kylie) #3

Hi,
I am using the GBRL-M3 already and tried a different one but still not $30 to $32
Im using V0.9 currently should I be using V1.1 and if so where do I get the new version

Thanks


(Oz) #4

GRBL 0.9 doesn’t have those options, so they’re not expected to be there. If you want to get newer firmware for the machine you would need to contact the hardware maker.

If the machine came with software that runs the laser, does it have the option to save GCode to a file? If I could see the commands it sends I could likely tell what’s different.


(Kylie) #5

It looks like no its just a basic print program with no create or modify of the picture/program, it looks like its NC based, it called Engraver Master.
Can I just download another newer version of GBRL and wipe the controller and load the newer GBRL control on?


(Oz) #6

Probably, yes. Record the console output when you type $$ so you can put the original settings back, and I would contact the hardware vendor to see if they can tell you how to update the firmware.


(Kylie) #7

got it sorted
thanks