Hello i have an error on lightburn (g code words consist of a letter and a value. Letter was not found.)

I have a Sculpfun s9. It was working fine a couple days ago and today the laser doesnt move at all. I uninstall and install again lightburn and my device but the error is still there.
I try with RGBL and the laser shoot the blue and leaves a burn mark but doesnt move in that software neither. the error that is shown in the console is g code words consist of a letter and a value. Letter was not found.
I already check and g code clustering is disabled so i dont know what else to do.

With this eliminated, I suspect there is a communication problem between the PC and the laser controller board. Bad connection at a plug, bad USB cable, or possibly spark noise from some nearby equipment. I have never read any posting where Lightburn created bad Gcode syntax.

Does your USB cable have a ferrite on it?
Is there some new electrical equipment close by?
Have you tried a replacement USB cable?
How long is your USB cable? (10 foot maximum)

There is not new electrical equipment around the machine or the computer.

The usb cable is not longer than 6 ft. I was using the original usb cable that came with the sculpfun s9 since january and the one that I bought today is the same length. I’ll upload a photo of the cables.
I may see the problem on the console on lightburn on line 3 says: G0 X0 Y0

I do not think that is it. Gcode syntax is very simple: a letter followed by a number. G0X0Y0 is proper as long as those coordinates are within the area allowed by the controller. To test this, enter G0X0Y0 in the Console window and see what it does.

What you see in the Console window is not sent back from the controller. It is what Lightburn sends TO the controller. It will be ahead of what the controller is actually processing. The fact that the code sent looks good and the controller, being behind the stream from Lightburn, reinforces my suspicion that it is a communications problem.

I see no Gcode errors in your picture. Those first 4-5 lines are pretty standard output from Lightburn for most programs. Did you try a different project file to see if it repeats the error at line 2 again? Projects that ran in the past should continue to run. Try this and let us know what happens.

Ensure you have selected plain GRBL in the Device type menu:


The other choices let LightBurn generate G-Code commands your controller can’t handle.

Yes sir. I tried with old files that i commonly use and new files like a square just to frame it and the laser doesn’t move. I deleted the laser from lightburn and added again and still same problem. And also says “feed rate has not yet been set or is undefined”

Yes, my laser was set like on the image you shared but just in case i deleted the device and i added again. But didn’t work.

That is a different error than you mentioned before. Again, it is reporting an error that is not true. Your Gcode shows F2000. You are operating in mm/minute mode, right?

Try this… draw a simple 20mm x 20mm box and set the speed at 500mm/min and power at 50%. Save it as a Lightburn project file. Then Save Gcode to a file named Mikey.nc where you can find it. Now select Run Gcode and report what happens. If it fails, rename the .NC extension to .TXT and upload it here. Also upload the Lightburn file for the box.

I know there are several requests here, but the answers are all helpful towards solving your problem. Before we can fix it, we have to know what is broke.

I flash the firmware from GRBL software and now the laser moves and frame the projects but its super slow and make weird noises. doesnt matter the speed that i put it just goes slow, please hear the noises from the video is like is slowing and then starting again to move. https://imgur.com/s7eRnYH (link for the video)

Yes and I appreciate, while I do all that, do you mind check the update that i post? i flash the firmware and now the laser moves but slow and makes weird noises that didnt do before.
And I post this error since yesterday in Sculpfun s9 users groups and theres one person that says that is having the same inicial issue.

I did all that and ther was not a problem on console, i open the Mikey.nc file on lightburn and first i frame the square and then i start the project. It works but it´s going slowww thats not 500mm/min its going like at 100mm/min and its making the noises from the video from the other comment. Im sorry if I dont explain myself very good, this is not my first language.

Where did you get the firmware?

Can you run these commands in Console and return output?


I have the firmware from here Firmware Update & Settings - Diode Laser Wiki
Waiting for connection…

Grbl 1.1h_S6S9misken [‘$’ for help]




Target buffer size found





Target buffer size found






































The laser was framing the objects in lightburn and i close it and open the software and now i try to frame a square and have to stop it because it went out of boundries to the right side (i did a square like 20mmx20xx)

The Misken firmware should be fine. But you need to restore the default configurations in that case.

Run in Console and retest:

1 Like

YES SIRRRRR. That fix my problem now the laser moves rapidly as it should. BUT I open a new project in lightburn and frame it and everything cool and if I add another form to the project or if i move it on the sheet the laser doesnt care and keeps framing the first position that i gave. ill upload a video: https://imgur.com/a/5igxwKq

This is a familiarity issue.

You are using Current Position as the Start From mode in Laser window. So the behavior you’re seeing is what you’d expect.

Try the following:

  1. Turn off laser
  2. Move laser head to front left of laser, then turn laser on. This is called manual homing. You will need to do this since your machine doesn’t come with homing switches
  3. From this point forward do not ever mover the laser head by hand. Using the jogging controls in Move window only.
  4. In Laser window, switch Start From to “Absolute Coords”
  5. Retest

You can learn more about the different Coordinate methods here:
Coordinates & Origin - LightBurn Software Documentation

You explain just fine. I hope what I say makes sense to you.

Looks like you are on the road to recovery. It looks like @berainlb has joined, and he is very good at this stuff. I will try to not get in his way. :nerd_face:

1 Like

Yes I did that and then close and reopen lightburn and everything was perfect.
Thank you so much guys (to everyone).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.