I have a BOSSLaser HP2436, everything was working fine with the Trocen-AWC setting over ethernet until I updated Lightburn.

Now I get awkward behavior, for instance if I position my design in the center of the board and send the file to the laser it attempts to cut it as if it is positioned back right.

When attempting to “Frame” the design the framing occurs only in relative position of the current position. NOT the designs true X/Y.

All etch/cuts are now assuming I have material in home position at 0,0 - This causes the laser to assume designs are out of bounds and abort.


No need to shout - there’s a version archive here:

Which version were you using before?

The behavior you’re describing is likely because of bugs that were fixed. The Trocen controller has a menu in it where you can select the job origin type, and it sounds like you want machine coordinates, not user origin (which is the default).

On your controller, do this:

  • Press the “Menu” button
  • Go to “Common Parameters Settings” and press enter
  • Go to “Work Mode” and press enter
  • Go to “Origin Mode” and press the left arrow to change it (I believe you want Soft Origin, but it might be Machine Zero - I can’t recall)

If you need to change it back, just follow those same steps, but pick Key Origin (or whatever your machine is set to now)

I have tried both Soft Origin and Machine Zero, the laser is still framing the artwork at 0,0.

If i position the laser head, then frame it frames it from the current laser head position, but as soon as I send the file it still treats it as if it is 0,0

I attempted to go back to my previous version with no luck. This is very disappointing as I only have the weekends to run my jobs and now it looks like all my time will be attempting to fix this.

Even after attempting to remove all LightBurn and reinstall with the newest it seemed to remember my key and personal settings, is there a way to completely remove lightburn and reinstall from scratch to see if this will correct my issues?

What do you mean by this? Were you unable to install the old version? Did you uninstall Lightburn before attempting to install the old version?

This will not correct the issue. The way Lightburn interacts with the Trocen controllers was changed due to the inability to alter their origin mode from Lightburn.

Do you need absolute positioning? If not, changing the Origin Mode to Current Position should do the trick.

I was able to install v8 no problem, connected to the laser via IP and the issue remained.

When i removed all versions of lightburn went back and installed it again it was like my user preferences remained intact.

I want to attempt to completely wipe llightburn from OSx like it never existed, go back to v8 and install it the way it was previously working.

What origin mode were you using on the controller when you were using version 0.8 of Lightburn? I don’t think any of the user settings in LB will effect this issue. Try setting the controller to Current Position (I think that is the default on a new controller) and running a job in LB 0.8. Let me know what that does.

As for wiping LB off the MAC entirely, I am not sure of the answer. I do not use LB on MAC.

The way i always used the laser was place materials in the center of the machine, use the “Set laser position” tool to get the laser over my material, then focus the laser and frame it.

From there i would start the job, the laser head would return to 0,0 then move back to the center of the bed where it would begin to process the job.

Now it only runs jobs starting at 0,0 and that will never work correct for my engraving of large items when i have to use my pass through doors. It also does not give enough space for the ramp-up because it says the artwork is out of bounds.

I have never changed it, but when i followed the instructions it was originally set to “Key Object”, but now i’ve tried all of the available options with no luck

OK. In that case all you need to do is set the controller to use the Current Position for the Origin Mode. You can manually position the laser head where you want it and go from there. That will work in the newest version of LB. I have a Trocen controller myself and that is what I do.

Not sure why. Current Position works the way you described your work setup.

Well reset everything and Current Position is now working as i need! Thanks you.

The only new thing i see is this new message. It still sends the file and it works as expected but lightburn shows this regardless.

Thank you so much for your help!

That’s an odd one - it should only report that if the controller reported a problem. I’ll investigate.

Apologies for the original advice I gave you - your first post made it sound like you were trying to use the machine origin for the work, not the current position or user origin, so I sent you in the wrong direction.

Let me know if you want me to enable any logs or anything, i’ll be happy to attach. And no worry about the advice, you pointed me in a direction I had never been in so learning the variations was helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.