Help, Fonts no longer can be Boolean Subtracted?


(Duane Blewett) #1

Since the latest update I can no longer subtract a shape with a font. Is anyone else having this issue? I use this feature regularly for monogram projects. This is significant for me as it affects my business. I tried work arounds; breaking the font apart but that resulted in many lines and curves which is not effective. Help


(Rick James) #2

Just checked Boolean Subtract using LightBurn version 0.9.03 running on OSX 10.13.6 (17G7024) and it is working as intended. Please rephrase, include steps to reproduce, and show examples of what you are starting with, the desired result and what is LightBurn producing.


(Duane Blewett) #6

Thank you for the quick reply. I am using a PC. I would like to cut the middle portion of the C out. I have done this several times prior to the latest update… drawing a rectangle subtracting a portion of the font. I have tried multiple fonts and that doesn’t make a difference.

You will see in the sample the Boolean Subtract button is grayed out when have have both the rectangle and font selected. I have tried select all, choosing the font first, the rectangle first… still grayed out.

I have tested two rectangles and it works fine.

After subtracting I add a line and weld the line to the top portion of the letter and another line to the bottom portion of the letter (Gilmour example).

I am a new user… only one photo per post for the time being. Will follow up with another image.

New user… would not allow me to reply with this image too quickly… =)

Hmmm here is something weird… When I have letters now it works…

Odd… from here I can draw a rectangle around the first C and subtract it. Something is buggy. At least I can carry on for the time being.


(scott hughey) #7

Glad you posted this because I could not get the boolean subtract to work with any shape on text . Works with shape on shape but not shape on text. I was trying to do the same thing for a project for my wife and gave up and did it in photoshop old school.
I know I have done it before in LB…? I am running a PC with a Ruida and I cannot get the boolean features to even be active (greyed out) with shape on text.


(Rick James) #8

Thank you for reporting this issue. We have generated a bug report and will be looking into this further.

For now, I have found that I can convert the text to path and then use the ‘Edit’->‘Close Path’ to then allow Boolean operations on that shape with another.


(Oz) #9

I altered the code to disallow doing booleans with simple line objects (open shapes). It’s possible that text objects fail that check - I’ll have a look.


(Oz) #10

Yes, I broke it, but apparently because the last letter in a text object wasn’t properly closed. I have fixed this and will try to get a patch release out shortly.


(Duane Blewett) #11

The quick response has been phenomenal! Thank you.


(scott hughey) #12

Cool…I thought it was me screwing up again…hahaha.


(Rick James) #13

I just pulled and checked the latest release and this issue has been fixed. Give it a go for yourself.