Help I have tried everything

I have a Genmitsu Jinsoku LC-40 and I installed LightBurn on my Lenovo IdeaPad Flex 5. I have tried everything I have researched to get the laser connected. I cant get it to connect.

Connect the USB cable to both machines. Power up the PC and laser, but click on nothing except the Console tab. Copy everything in the Console window (scroll it) and paste it here.

I have been trying different things and

now this is where I’m at. It gets stuck at 20% and it won’t let me close it or click anywhere.

I got it to here but can’t click console

With the laser on and USB cable connected, reboot the PC, then run Lightburn. When that loads, go to the Laser window and see if any COM ports are listed in the box nest to the Devices button.

If none are listed, you have a USB communication issue.

If a COM is listed and you can select it, do that. Then click on the Devices button and proceed to manually enter your machine info that it asks for. Controller type is GRBL, without any extra letters.

I don’t see any COM Ports listed. I can’t access the dropdown without manually entering a device.

Have you tried different port, different device plugged into port, different USB cable, checked device manager to see if it’s detected?


PC USB to cable looks good. Manually add your machine, selecting GRBL (no extra letters) and then see if it can connect to COM5.

It gets stuck on “waiting for connection”, and under Device Manager, it shows a different port in use. The cable doesn’t “ping” when I plug it in. It hasn’t since yesterday when I downloaded software that came with the laser.

I know I should not ask, but did you try COM3 and COM4?

How long has it pinged before it did not ping?

Have you tried lowering the sliders on receive and transmit? Maybe reinstall the driver.

COM 3 and COM 4 are Bluetooth. I have tried so many different things, I don’t remember how long it pinged.

I don’t know what lowering the sliders is. My computer skills are basic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.