Help please with my software

Hi I have just changed my board from the nano m2 to cohesion 3D… I have installed light burn to run the machine … So the software is installed OK. I open up light burn for the first time it finds the board and smoothie software the board is lighting up as it should with a red light couple of green lights a some green flashing lights I am told that’s how it should. When home is pressed in the software it goes to the top right hand corner. If I try to jog the laser head to the right it goes to the left. If I try to move the laser head away from the top right hand corner it tries to move up and starts rattling the laser head … Basically everything is working in reverse. My laser machine work area is 600 x 400 mm again this doesn’t work … Can anyone tell me what I have to do to fix this please … I haven’t changed any software settings. Below is a picture of my machine and my nano m2 board

This is my board

Change direction of stepper motors in the config.txt file

Sorry I don’t know how to do that plus I think I forgot to say its not firing the laser and the laser head when moving is moving very fast

This would be something to ask on the Cohesion3D forum I would think. They should be able to help you.

I have asked on their forum with no reply …

Well it is a long weekend, I know I would not want to be working this weekend myself :slight_smile:

try changing your origin on lightburn to the opposite corner, it can mirror the machine if incorrectly set. That would be those 4 dots in a grid.

There’s likely going to be configuration changes required to the Smoothieware config file on your new board in order to set it up for your machine, and changing the device origin before doing that may just confuse things. You will definitely need to change the travel distances, and probably calibrate the step sizes, and might need to change some information about the homing and movement directions. I would wait until those things are settled first.

1 Like

Thanks sounds as if it would fix it out but how do I do it … The cohesion board was bought online with a rotary attachment from the USA and I am in Scotland in the UK. … I take it it will be the Cohesion people that have written the software and how do I change these settings. As I say I have left the same message on their forum with no reply yet.

on the Sd card there is a text file called config.txt. Open this and you will find the settings to edit within. Make sure your steps sizes are right on x and y, verify by cutting a square or maybe 50x50mm and then measure it. if its off then you need to adjust them. Also make sure the bed size values for x and y match your available space on the actual machine. You can either measure it or manually jog to one corner and count the distance you can jog until you hit the other side/limit switch if installed. Editing these values are relatively easy and most have notes next to them to explain their functions. More info is available at http://
smoothieware.org/configuring-smoothie and http://smoothieware.org/configuration-options.

Fantastic this was the kind of reply I was looking for I will try to look at it on Tuesday as I have work for the machine to do and once this is done I can look at what you have explain … Do you know why the laser is not firing and the laser head is moving very very fast … Could these fault also be looked at in these settings.
Thanks again for your advice.

Hi I have tried that but it makes no difference.

Hi I tried that but it made no difference the laser head stayed in the same position

for those I would check the acceleration values also, and try tweaking them to a lower value. For the not firing that would relate to the Laser Fire pin, however the standard config generally works. i would double check the wiring itself. Note that the laser generally fires when you ground the L pin, and the C3D board(like the smoothieboard) does this through a mosfet. Also check that your WP(protection loop) is grounded as this will also prevent firing of the laser. If you have a water flow switch or door interlocks these are in that loop and a failure will break the loop as a safety. Water flow switch’s are notorious for causing this.

Hi but if there was anything wrong with these thing would they not stop the nano m2 board from working because I have had to put that board back in to get these jobs done and the machine is working great.

The nano board will have its own settings for how fast the motors can move, how many steps a motor needs to take to travel one mm, how fast the motors can accelerate, and how large each axis of the machine is. All of these settings were specified by the manufacturer of your laser. Replacing the control board with anything, C3D or otherwise, means you must transfer those settings (or determine appropriate values for them somehow).

The C3D is a drop-in replacement for the K40, so the settings that ship with the board are for that physical unit. Using the C3D in other lasers is not hard, but means the settings must be adjusted accordingly.

I would say you are 100% right have you any idea how I could get the settings from the nano board so I can apply them to the cohesion board

Have a look through these threads on the C3D forum:

The values mentioned there are all in the config.txt file on the SD card in the board. I would say if you’re new to this, the best thing you can do is wait for guidance from C3D, or at the very least, back up the config file you started with before making changes.

You’ll need to calibrate the step length for X & Y, set the alpha_max and beta_max values (X and Y axis lengths) and possibly change the homing directions. The last one I’ve never done.