Help setting up

Hi, I have recently purchased Lightburn and i have also purchased a desktop 550MW Bachin laser from Amazon. I have manually set the laser up in Lightburn as GRBL but i am unable to connect to the laser. The firmware version is GRBL1.1F and i am running windows 10. Can anyone please assist me with the issue as i would really like to start using Lightburn.

Did you receive any software with this laser? You may need to install the drivers for this laser system.

In LightBurn, did you try the ‘Find my Laser’ to set up this device? What result did you get?

Here, we provide our setup documentation worth review:

Hi Rick, I did received software with the laser and I have installed the drivers. I have checked that they have installed in the device Manager and this is listed as CH340.

I also tried the find my laser to setup the device but it wasn’t detected.

Just for clarity, you can successfully run the laser using the supplied software, but cannot connect using LightBurn? Did you select a com port when trying to connect using LightBurn?

Yeah the laser will run with the software supplied with it, but it won’t connect through LightBurn. The laser is currently on com port 9 which is what I selected in LightBurn as well.

So I tried today again to get the laser communicating with LightBurn. I uninstalled the drivers and then reinstalled them. LightBurn still wouldn’t find my laser, so I tried to set it up manually and still couldn’t get any communication. Can anyone advise me of anything to try

Is this your first time trying to use lightburn? I currently have this exact same problem with a NEJE Master 2, 20W laser, but i had no problem connecting to lightburn when i had the free trial. after the trial ended, and i purchased the license, no bueno! Console tab just states “waiting on connection…”

You’ve already flashed your controller with GRBL1.1f?

I have used the trial version on my larger laser, but I decided to purchase the full version to use on the smaller desktop laser but still not been able to get it to connect. I am getting the same message in the console tab as you.

The controller has been flashed with GRBL1.1f

Not sure what else to try now slowly losing the will…

I’m researching more on the forum and online to understand GRBL and how to set it up without flashing the laser with grbl1.1f, as clearly that’s not working. if i find a good solution or have any luck connecting i’ll respond back.

just out of curiosity, what baud rate did you use when flashing the files to your laser? i keep cracking up as i’m typing… feel like we’re both blind :stuck_out_tongue:

When I flashed it I did it at 9600 baud rate. I wasn’t sure it had worked first so I I installed the old software that came with my laser to see what version it was and it showed as been updated to GRBL 1.1f.

Hopefully we will find a solution soon.

I just read this morning where someone had been using a previous version of lightburn… 9.16, and their laser connected without issue. When they downloaded the 9.20 version, it would not connect.

When i purchased the license, I updated lightburn to the latest release, and that’s when i’ve been having this issue. I haven’t had a chance yet, but i’m planning to try a previous release of lightburn tonight. If you get to it before i do, best of luck!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.