Help! The X, Y, and Z axis have a mind of their own


I am trying to use a Ruida controller, RDC6445GT5, with a Full Spectrum Laser, PS24, and Lightburn. When the controller is hooked up to the machine the x, y and z axis will move slowly on their own without any input. The direction of the move changes but is generally x and y away from the origin (top right of machine) and z moves down. When the axis is moving on their own triggering the respective limit switch will not stop the movement. I have swapped the controller out already and the problem persists. Looking for help fixing this problem.


This sounds like a new, but not yet configured, controller installed in an existing machine. Is that the case?

If so, did you extract the previous controller’s configuration with Edit → Machine Settings → Save to file, then load it into the new controller with Edit → Machine Settings → Load from file?

If not, then Edit → Machine Settings → Load from backup may help find the most recent automatic backup file. Pick a date before you installed the new controller to maximize happiness.

In either case, the Write button will stuff the configuration data into the controller, after which a power cycle should start it up properly.

Aaaaand if none of that improves the situation, then you’ve got other problems … :grin:


Thanks for the info, the instructions helped but didn’t at the same time. Now when the laser is controlled directly from a computer via Lightburn the drift does not occur. However, when the controller is hooked the drift always occurs but it is now away from the home position (back right corner) and down on the z.

My gut says it has to deal with stepper drivers, but this is just my gut instinct and what I am looking into now.

I’m still not sure what condition the machine is in and how it got there.

  • Did it work previously?
  • How did it fail?
  • Is it now running with a new controller?
  • Did you successfully load the old controller’s configuration?

Until the machine will home successfully, do not use LightBurn for control. You will use LightBurn to read and write the configuration data, but do not do anything else with it.

This post summarizes what you must do for each axis:

After you have homing settled, you can proceed with calibration and suchlike.

After looking at the post and follow the intent, the y axis is NO, the x and z axis are NC and the polarity is now correctly set. The drift still occurs but now takes about 7 minuets after being turned on to begin and it will ignore the limit switches when drifting. :face_with_diagonal_mouth:

Trying to answer each bullet point:

The history is:

Was using the Full Spectrum Laser (FSL) controller which came with the machine. It was working fine until the controller got “marked stolen” (very long story involving this fiasco), after the machine controller was unlocked it started acting odd. Odd being sometimes it wouldn’t cut layers, ignore cut order, ect… This has lead to the FSL controller being traded out with the Ruida and making the switch to Lightburn software.

The system will run with the new controller and when the controller is plugged in it drifts <10mm/sec away and down from the home position.

Was unable to load setting from the FSL controller but loaded from a different controller / machine and changed the work space area configuration only.

No longer think its the controller since it will work on and OMTECH AF1630-70.

That’s key to thinking it’s a configuration issue.

This may point to having the distance/step values totally incorrect, along with the various speeds.

A post on figuring the correct distance/step, for which the 6445 apparently uses µm, rather than millimeters:

If you typed in a value in millimeters and the controller interprets it as microns, then every step will be 1/1000 whatever you think.

Verify that, then set the max speed to 300 mm/s and the max acceleration to 3000 mm/s². Set the homing speeds to 100 mm/s. All of those can be tuned later.

Then it should trundle along at a more reasonable rate when you first turn it on, whereupon you can get the homing direction / switches / speeds working properly.

Well, the settings were already at the ones you recommended, so took a deep dive into the DM442 drivers. The x and y stopped drifting after the pins controlling the current were corrected. The z axis is still drifting down, but am trying to learn how to use the DM442 software to correct it.

New information enters the chat … :grin:

What was the original switch setting?

What software is this?

One of the DM442 manuals I found says:

Note: This drive is only suitable for long-term constant speed applications, not for applications with frequent speed adjustment.

That suggests it’s not an appropriate stepper driver, because “frequent speed adjustment” is pretty much the definition of what a laser cutter does. The full DM442 datasheet does not include that note, but does emphasize “low speed smoothness”.

Have you run the driver’s auto-tune operation?

Did the laser have those installed as original equipment?