Help... When I press START, laser goes home

One of my limit sensors broke so I got new ones from xtool and installed them. But now after I frame the design and then press START, the laser just goes home - and the processing thinks it is cutting as the “clock” or timer works but just goes on and on. I have contacted Xtool and says not their issue. I have watched a lot of videos, and can’t figure out what is wrong. It must be a setting in lightburn? I have only used the basics of this program - so any help would be appreciated. Thanks!

Does your limit switch have three terminals?
Wired correctly?

Yes - one got damaged and I replaced it and the other two are still fine. But I have checked and they are all connected according to instructions. It’s just odd as it was working and now when I press start, the laser goes HOME. When I use XCS - and I press the button, it starts to cut an old design. I have tried to reset the laser but really can’t find an easy way to do it.

Hi Ray.

I haven’t used mine enough to have encountered the behaviour You’re describing, but as a fellow xTool owner, a few things come to mind.

First, if Your laser is brandspankin new, there have been quite a few reports that the USB cable that the xTool supplies with the laser was (maybe still is) bad, I for one had very weird problems ~1,5 years ago when I bought mine.
Those weird problems went away when I replaced the USB cable.
The rest of the weirdness pretty much went away when I ditched XCS and started to use LB :wink:

Secondly, (applies obviously to other brands than xTool as well) how did the limit switch get damaged, is it possible that something else got damaged as well?
Haven’t tried it, but IIRC the PRO works just fine with the switch(es) removed, what happens if You unplug the switch, move the head to the middle of the workfield and burn a small test shape?
Obviously You have to be ready to stop the laser quickly if it still decides to go home.

Thirdly, there should be a “write enable” switch on the xTool controller for firmware flashing purposes, is that off?

That’s odd, can You cut anything else than the old design with XCS?
IIRC the work files are stored in the SD card, and run from there, so inability to cut anything else may suggest that there’s something wrong with the controller.

I’m unable to check my machine ATM, but IIRC there is a reset button on the xTool controller on mine.
Haven’t used it though, so I do not know what it resets, if anything.

Reflashing the firmware -or upgrading it if You do not have the latest firmware- may well be the fastest option to get Your machine resetted and operating again.
As always with firmware upgrades, if You have made changes to the operating parameters and flashed them onto the controller (in this case with XCS), it pays to back them up somehow.

Regards,
Sam

:finland:

1 Like