Help with Engraving Issue - Start of Scan line is faint

I have recently purchase a G-Weike 1390N (1300 x 900) chinese laser. Everything is fairly standard for a larger machine, belt drive stepper motor system, Ruida 6442, 100W Reci tube etc.

The issue I’m trying to solve is with the alignment/quality of the scan/fill lines. I noticed my engravings didn’t have good hard edges, so I have been running some tests to look at each scan line.
At first I thought it was simply a matter of adjusting the Scanning reverse compensation, but that didn’t work like expected. As soon as I added any compensation the alignment of the lines was over corrected and edge alignment became worse.

I’ve attached a couple of images showing the issue.

Img 1 - This is a square engraved at 400mm/s with X scanning in both directions and 0.4 scan gap and there is no reverse compensation. The lines are actually lined up and start at the same point horizontally, but if you look closely at the faint engravings at the start of each line. When the line starts the laser power hasn’t reach the full power straight away and there is a small section of faint engraving before the darker engraving starts. So from a distance the lines look like they aren’t even.


Img 2 & 3 – This a square engraved at 400mm/s with X scanning in only one direction (left to right) and 0.4 scan gap with no reverse compensation. You can see the start of the line is faint (left hand side) before the full depth engraving starts. Also the right hand side does not always finish at the exact same point.

Does anyone have any thoughts on what could create this issue and any ideas on how to fix it? Is it a hardware issue or software issue?

Thanks in advance.
Mat

Hi, Have you checked belt tension and i would maybe add some overscanning when engraving to allow the power to ramp up before turning on, try like 10% and if that works maybe titrade down to a smaller number that still works.

Hi Alex, thanks for your reply. Belt tension seems good, there is no movement in the head when the machine is powered on. I also don’t have any issues when cutting, only when engraving.

I don’t have an option for Over scanning in lightburn. As far as I have read, lightburn removes the option when using Ruida/DSP controller as it is adjusted automatically by the controller based on acceleration settings. However, at the moment my machine does have plenty of over scan with the head moving at least a couple of centimeters either side of the image as it is engraving.

Cheers.
Mat

sorry couldn’t be of more use Mat, I run grbl myself. Being that you already tried compensating for the belt, I’m not sure what else it could be. I had something very similar happen, only when engraving and all I needed to do was use overscanning and it went away. Perhaps you could mess with your boards accel settings. Maybe by turning your accel up it will trigger your laser faster reducing light the light.

Best luck,
Alex

No problem, I appreciate the replies and it certainly helps to go through things with someone else. I will definitely try changing the settings for Acceleration and see if there is any difference.

Thanks again.

It’s not mechanical. Don’t introduce new problems.

Your lpsu doesn’t seem to be able to rise quick enough.

What make/model?

Hi Bo, The power supply is a ZYE MYJG100W-Y driving a 100W Reci tube.
Is there anything you suggest checking to see if it is a power supply issue?
Thanks

I’ve run a few tests using the built in mah display on the psu. I set my Ruida max power to 30%, 50% & 80% and did a pulse for each, these are the results:
30% = 12mah
50% = 20mah
80% = 30mah
So it seem my psu is set too high. Not sure if this has anything to do with it, but I will have to reduce the output and re-test.

@LightBurn G’day OZ, Just wondering if you have ever seen this issue before? Cheers

We offer a bit of background and a software adjustment to help that is worth review. Scanning Offset Adjustment - LightBurn Software Documentation

Scanning Offset Adjustment

Modern lasers are capable of moving very fast, and with remarkable precision, however firing the beam still takes time. Some power supplies and tubes may respond in microseconds, but others take longer. At higher speeds, belts will pull slightly as well, and all of these things can cause the output of the laser to shift slightly when engraving…

To update further on the issue I was having with the engraving. I swapped out the power supply for another from an older machine rated to 100W and the problem has gone away and engravings are crisp and aligned.
This was also without needing to add any reverse compensation either. So for some reason the power supply with my new machine either isn’t as good, or it is faulty from the start.
Hopefully this can help someone with the same/similar issue.
Thanks.