Help with grayscale engraving

Hello there

I just got my new Eleksmaker a3 pro a few days ago, i’ve been tinkering with the original elekscam, but it didn’t work at all and was throwing many error messages, then i tested t2laser buuuut it would stop working because i had no license (even on their own sample engravings), so i ended up trying Lightburn.

I have a Eleksmaker A3 pro with a 2500mw laser and i flashed to grbl 1.1.

Its working really good so far and i like the interface, but im having problems trying to get grayscale images working, it works, but not as expected, it makes much lighter burn when its supposed to use 100% power (on full dark areas), maybe i need to do something or configure some parameters im not aware of.

This is the image i tried to engrave to properly test the grayscale things (since im a new user and i cant upload multiple images, i did it with imgur):

And this is what the laser did (speed 60 mm/s with grayscale dithering):
(Ignore that the image is flipped, im dumb and i connected the motors wrong)

For additional info, i did this thing with Threshold just before doing the image above, you can see the burn areas are darker:

Images ordered with descriptions

Im using some birch plywood sheets i bought on amazon (A4 size with 3mm height)

Thanks in advance

My first guess is that 60mm/sec is far faster than you’re going to want to engrave with, having a 2500mw diode laser. I engrave at 100mm/sec with a 100w co2 laser.

I’d slow it down considerably, and see if that doesn’t help.

I guess i would need to reduce the max power too if i slow down it a lot

Based on the pictures you provided, you have several issues going on here.

You mention your speed setting in mm / sec. As Blake identified, you may want to slow that down a bit. I suggest you change the Units to mm / min from the ‘Settings’ window.


You have identified grbl 1.1 but left off the release letter. Typically the machine ships with an older version of grbl so go with the GRBL-M3 (1.1e or earlier) device in LightBurn. Ideally, you would upgrade to GRBL 1.1f and then use just the GRBL device. What does the firmware full version report from the console when connecting?

Share that and we can go from there.

It updated to 1.1g, i checked it with lasergrbl software i was trying this morning

You will need to choose the GRBL device in LightBurn.

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.

Yes, $32 is set to 1 (i did test to disable it, but it printed pitch black engravings), also $30 is set to 1000 too

EDIT: im testing right now a 13x12cm version of the percentage grayscale image at 1500 mm/min and 100 maximum power, its right now at 30% completion and i think its a little overburned, so maybe increase the speed to 1800/2000 mm/min would do it

EDIT2: It finished, my guess is to increase speed to 1800 and decrease max power to 90%

I printed this photo (25x17cm) with 2000 mm/min and 100% maximum power, it took over 3h (a little more i think) to complete on birch plywood (Edit: this was jarvis)

Overall i think it looks good, some areas could get a lighter touch so they get more visible on the engraving, the only thing i still cant get is the hair, i dont like the look of the hair (maybe printing at -45º angle was not optimal for this image)

Original image for comparison (i upload the b/n one because i manually edited the colors on photoshop to try and get the best i could for the engraving)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.