Help with homing

Don’t even know if I am in the right section.
I set up the sculpfun s10 with limit switches. Though not sure they are set up correctly. The machine doesn’t seem to recognise the limit switches when I home the machine through lightburn. It crashes into the gantry

When using absolute Co ordinates the green square appears to be minus 0 on the grid

Did you follow a guide on how to set up these switches for that particular machine?

Where do you have it set to home… top/right, bottom/left?

When you power it on, does the head move in the correct direction to engage the switches…?


Recollection it was rather tricky at the time so I am not confident they were set up
I wondered if I remove them
What would this do.
I can always re install them when I have more experience
It’s rather overwhelming with all the information on S10

Home is bottom left by the way

You can just disable homing… no need to remove them unless they interfere with normal operations, which they shouldn’t…

I’m not that familiar with these machines… Maybe @berainlb knows more about these and can be more helpful…


Thank you for that. Do you know how to disable homing as you can probably tell I am a novice!

Thank you - think I have now disabled homing €20=0
Seeems to have done the trick

Take a look here: Limit Switches - Diode Laser Wiki It explains the full process of adding limit switches and the required settings.

Thank you . I have disabled homing for now but not being one to give up I will check this out in the next day or so. Thanks again

Well aren’t I the numpty. Operator error … the limit switches had moved. Problem solved
Thank you guys x

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.