Help with not centering burns and have to mirror text

I have a xtool d1 with the extensions. Now when I go to burn anything I have to start it in current position center right for it to actually burn in the center. Also it has to be mirrored for any text and pattern to come out correctly.

Was this working correctly before adding the extension? Or is this a new unit?

Did you originally create the device with the .lbdev file supplied by xTool? I suggest you do so if you haven’t. Then you will need to adjust the size of the laser.
Link to .lbdev file from xTool:

Link to another user getting extension working correctly with links to instructions about changing workspace area:

So here’s what’s going on. I ran a test with the x-tool creative space and it was perfect.
to get it close in lightburn If I set it for current position center I have to place the cross hairs centered but almost at the left side of my project. If I use current position right side center it burns okay. Plus all texts still have to be mirrored. I did the .lbdev update

Set Start From to Absolute Coords.

Then if you start the machine with the laser head at top-left. Are you able to jog to the far lower right? What is the reported position?

so I set my x & y Axis to top left . My settings are x=490 y=930. I jogged the laser from top left x=0 y=0 down to the bottom right. my readings were then x=490 y= 930. But it still frames correctly but burns offset to the right.on the x axis starting from current position center. However If I start it from current position right center it burns correctly. is some how the offset on the laser off?

Are you using crosshairs or primary laser for framing?

By how much is it offset?

Can you take a screenshot of Edit->Device Settings?

All set. Finally found where my settings for the laser offset was. Adjusted it and now working great. Don’t know how it got shut off but everything is great now. Thank You for your patience and help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.