Hide Z-Axis Controls (bug or feature request?)


(Ben) #1

I noticed on the LB Move Tab that there is a button for ‘Focus Z’ even though I’ve turned off Z axis in ‘Device Settings’ If clicked, it will cause my Ruida controller glitch & restart. I did not see quite the same issue with the up/down arrows however.

I would presume that the Z-Axis controls should be hidden if 'Enable Z-axis" is not marked.

And, as an aside - how easy and/or valuable is it upgrade my Red & Black 600x900 to from motors to steppers/autofocus :wink: ?


(Oz) #2

“Z enable” controls whether LightBurn emits Z moves as part of the job or not, for Z-steps per pass or Z offset. I still want users to be able to jog their Z up & down and focus, regardless of that setting.


(Ben) #3

Oh - I see. Then file this as a feature request. My primary concern was that when I was using a touch screen pc & hit the ‘focus Z’ by mistake and it reset the controller on the machine - perhaps LB could determine if either focus or Z-axis was controllable and disable the button if not

That is I assume that enabling z-axis control would not be easy to do in a configuration step I’ve just missed – I assume not and it would require converting motors to steppers?

I’ll note that I have a 900x600 Red & Black with Ruida & 2 buttons on the right side to lift the table up & down.


(Oz) #4

Conversion would mean changing that motor for a stepper motor, adding a 3rd driver board, installing a limit switch (if you wanted to home it) and wiring the connections to your controller. The wiring part is easy enough, but I have no experience changing those DC motors for a stepper.