HL-1060L with Ruida 6442S DSP controller - Y axis occasionally hangs up when doing "Frame"


(Daniel Near) #1

I’ve had my laser cutter for just over a week. I’ve been testing LightBurn on a Ubuntu 18.01 system since the second day after finding RDWorks in Windows unintuitive. I’m usually manually aligning the piece with “Current Position” aligned in top-left corner of the piece and the piece placed roughly center in the honeycomb.
A few times yesterday, when I tried to do “Frame”, it seemed like the system hiccuped and tried to move faster than it could step. Thus, the stepper made a bit of a racket while failing to move and the control system lost a clue on where it actually was. I had to reset the machine, let it re-home, and re-align to the work piece. Has anyone had to lower the motion speeds to stop this type of issue? Also, despite checking the radio button for top-left and using “Current position” it always seems that current position in the software is about 10mm negative to the Y-location in the software. The green locator dot isn’t on the corner of the cut path but above it. Making it harder to get the initial alignment right.


(Isaac Barbary) #2

A few times yesterday, when I tried to do “Frame”, it seemed like the system hiccuped and tried to move faster than it could step

Either the gantry is hanging up on something or the acceleration is set to high. With the machine turned off, does the gantry move on the Y-axis smoothly? No rough spots and it moves easily?


(Oz) #3

Check the speed you have set in the “Move” window, as that is the speed used for framing. You might have changed it and left it too high, possibly?

The green dot location is always at one corner (or side) of the bounds of the job you have chosen. For example, if you made a circle, there would be no “corner” of the cut path - just the corner of the bounding square that contained the circle. Does that make sense?


(Daniel Near) #4

I checked last night; When it gets near a certain spot, there is a slight increase in tension or tightness of movement. below 400mm/s (Where I was usually engraving at), it doesn’t seem to have any effect.

I haven’t changed any of the default settings. hadn’t even found where they were yet.

As for green dot misalignment, here’s a short video taken on my iphone showing the difference. (The laser indicator is actually +5mm on Y axis from actual laser position, it apparently got bumped) It should be right in the corner of the box - but the software shows it in a different place than it actually is doing ‘frame’. With some other attempts, the green dot might be in the actual corner of the box, but the laser will move Y direction about 8-10mm then draw the square… thus it’s still off-location. Software version should be 0.9.02, downloaded on 5/25/19
Frame operation doesn’t match green dot location


(Oz) #5

You have a stray graphic in that file:
image

Bandbox select it and delete it. If it’s part of the other black outline you might have to ungroup first to delete it, but I suspect that’s the offset issue.


(Isaac Barbary) #6

Damn, I missed that. Too busy looking at the other corner.