Home and design of the grid

Hello everyone,

I need your help.
I have this grid.
it is going off by little.
as you can see on pic blue is where it should fire at home position when i manually push it. When i click to home it will fire at where red arrow is which is little off. i am using lightburn and i have absolute coordinates. anyone came across this?

This is an excellent observation.

With an Auto-homing laser the engraver head moves to the origin position, trips the limit switches then moves away from them by a programmed amount and calls that new spot home.

If I am reading your grid correctly, You are working on the Top-left corner of the bed of your X-tool. I believe the limit switches are both in the bottom left corner - but, Please do confirm this as I don’t have one on hand.

I believe that this is what allows you to engrave all the way to the top edge and what is likely stopping you before the limit switch on the left (X-axis).

I feel that the click may be the limit switch as you push the laser head beyond the switch. A common pull-off setting is 3mm - what I suspect that I see here looks more like 8mm.

You may have a Work Coordinate Offset enabled.

In the Console window in LightBurn, please request the following two reports by typing:
$$
$#
then copy and paste those into a reply here.
The first report will tell us what the ‘pull-away setting’ is for the limit switches and the second will tell tell us if there is anything atypical about the workspace or coordinate system.

If neither of these reports reveal the reason for stopping before the edge, It may be that the click isn’t the limit switch. At that point, you may want to carefully inspect the belts, bearings and drive wheels for debris or damage.

I am having a similar issue.

The XTool D1 Pro comes with limit switches on both ends of the X and Y axis. They are some type of inductive sensor so they do not click. The machine homes to the top-left corner.

The clicking being heard is likely the stepper motor skipping a step or possibly the belt skipping a tooth due to the gantry/laser head running into the frame.

I am guessing the OP, like me, is using the red cross hair function for framing and using the “Enable Pointer Offset”. Which I believe the config file from xtool sets at X -16mm,Y 0mm (I found mine is more accurately X-18,Y0).

So what is happening in normal use if trying to draw the perimeter of the work space is as follows:

  1. Home machine to 0,0
  2. Frame with red cross hair pointer (works fine)
  3. Return to 0,0
  4. Hit Start
  5. Machine tries to move the Laser to the cross hair pointer (X0,Y0), moving the X -16mm
  6. This moves the gantry left either triggering the limit if enabled or hitting the frame and losing steps

What I think should happen is when the machine homes to the limit switches the machine should set the absolute coordinates to the Pointer Offset (X-16,Y0). This way anything in the work space will be reachable by both the cross hair pointer and the cutting laser. (Machine may lose 16mm of works space on the X+ side, but this is easily fixed by adjusting the Working Size value in Device Settings)

I have not found a way for the homing routine to set the Absolute Coordinates to something different than 0,0. I’m not sure if this is on the firmware or the lightburn side of the software. The only current way around this issue is to use the laser spot for framing and turning off the Enable Pointer Offset.

Hopefully this helps clarify an issue a few people are having and perhaps someone will find a way to fix.

Thanks,
~FierceSun

From my machine:
$$
$0=1
$1=0.03
$2=0
$3=0
$4=0
$5=0
$6=0
$10=255
$11=0.0
$12=0.0
$13=0
$20=0
$21=1
$22=1
$23=0
$24=25.0
$25=3000.0
$26=250
$27=1.0
$30=1000
$31=0.1
$32=1
$100=100
$101=100
$102=0
$110=18000
$111=6000
$112=6000
$120=2500.000000
$121=300.000000
$122=300
$130=432.000
$131=406
$132=0
ok
ok
$#
ok

alot of people in different forums having this issue.
What is not completely logical for me before i create grid i idid not manually push to home.
And after i make any coordinates it is off from my grid. and i did grid 2 times already same issue and it is off by same distance. what i can do i want be precise it would be headache to add those mm to add to every design that i do.

what should I put for value for size in working area ?

This is from my machine

$$

$#

$0=1

$1=0.03

$2=0

$3=0

$4=0

$5=0

$6=0

$10=255

$11=0.0

$12=0.0

$13=0

$20=0

$21=1

$22=1

$23=0

$24=25.0

$25=3000.0

$26=250

$27=1.0

$30=1000

$31=0.1

$32=1

$100=100

$101=100

$102=0

$110=18000

$111=6000

$112=6000

$120=2500.000000

$121=300.000000

$122=300

$130=432.000

$131=406

$132=0

Does your machine home before each job (not just when you turn it on, but before it starts cutting after you hit play)?

no it never goes to home by itself I have to manually press to home every time

Ah! I find I have the most reliable results when I have the machine home before each cut.

You could add a homing command $H to the Start GCode in the Edit > Device Settings window (GCode tab).

That said, I agree with JohnJohn that this looks like it might be an offset in the machine settings, here’s a list of all the settings and what they mean: https://www.diymachining.com/downloads/GRBL_Settings_Pocket_Guide_Rev_B.pdf

Your homing pulloff ($27) appears to be set to 1mm, which would offset it a little bit, though it looks like more in your image, hard to tell! But worth setting that to 0 to test it.

You might also need to play with the $130, $131, $132 values if your grid 0,0 point on your cut piece isn’t in the same corner as your machine’s homing switches.

The homing pulloff moves the axis far enough away from the switch to ensure it “unclicks” and opens. Setting the pulloff to zero means the switch will remain closed and the controller may kvetch about finding it active at the start of the next command.

Cheap switches with lever actuators may require 2 or 3 mm of pulloff to ensure the switch gets properly cleared and reset after homing:

1 Like

You’re right. probably best to skip the testing of the offset.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.