Home on x and y axis

I’ve been trying to search through the forum topics to answer my question. Many discussions come close, but I haven’t found a solution for my laser head homing to back right corner and grinding.
Controller: Ruida 644XS
Limit switches? Yes, back (top) right – this is where I have set “home” to be.
Read/Open/Save/ Write config files - yes.

Display: X:10000 and Y: 10000.
Whenever I hit “Home” in Lightburn, the laser head goes to back right and grinds away. And whenever I boot up my laser cutter or press the Reset key it does the same thing. And whenever I try to position the laser head anywhere in the workspace using the set laser position tool / icon, it either does not respond or moves and starts grinding at the front of the machine.

I’ve tried various settings for the limit trigger, limiter polarity, and direction polarity under Lightburn’s Machine Settings. Now, I’m afraid that I may have changed too many different parameters that I’ve really kludged things up, but even when I disconnect the laser from the computer, I get the same problems – so I don’t think that Lightburn is the problem, but I was hoping it might be the solution.

Does anyone have default settings for rd644xs? i would like to compare with mine.




Make sure your home position is set properly. Mine is set bottom left. You should be set top left.

image

my origin is set on top right because switches are in that corner. I have upload a video on onedrive. can you please take a look it would mean a lot to me. on the shutdown laser i moved my hand x and y to let them find home.

i have tested, bought switch works fine. but something is still wrong.
TNX for help

First thing you do is make a backup of anything before you modify it, this is especially true with controller configurations.


Is the video in slow motion? Seems to be homing quite slow.

I noticed that you seem to have npn limits switches, if that’s the case, you have the inputs inverted.?

Has this ever worked and where did you get it?

Give us some back ground of what and how it got in this state…

If you look in the electronics cabinet, you can see the led’s on the controller. The limit switches are displayed there, so you can see them toggle. That will tell you that it’s making the controller externally.

Here is a quick video that shows this on my 6442g…

There is also the diagnostic display on the Ruida itself. Z/U → Diagnostics

Good luck

:smile_cat:

Hi JK,
I bought the machine from China last year in September. The laser worked perfectly untill last week. It started hitting the ends of the bed and i got scared and pressed the restart button, after that i turned it off and on again i got the same result. Surfing on youtube i saw that you can only do a default reset and that the machine should find home and switches by itself. when i did that i got same result.
Now iam thinking new approach… buy the biggest hammare and disassemble the machine :slight_smile:

i didnt touch anything except default reset…

If you set the machine back to the Ruida default, that is probably not a good thing.

I hope you saved the original factory configuration that it was shipped it with so you can restore it.?


The configuration items you changed do not change by themselves overnight. The last thing you need to do is start ‘tweaking’ a working configuration. If possible, restore this back to the original factory settings. We know that worked.


Don’t get frustrated, it’s just a machine and it will live again, unless you pull off your threat …

Did you check the limit switches as I showed in the previous post?

:smile_cat:

Hi Jkw

I am on vacation i will check it when i get home. Thank you for you help, wish you all best.

I had the same issue… Does the red light show on the x axis hall effect sensor when metal passes over it?
I had to replace mine recently as the switch worked intermittently. The wires are so thin and fail because the x axis sensor moves with the wires in the drag chain, but the y axis one is fixed in the corner