Home position incorrect

Greetings all. I have the XCarve CNC with a 15 watt diode laser. Up until a few weeks ago I was using a different program but a friend recommended that I give Lightburn a go. The other program worked well with the laser, never giving me homing issues or connection issues. However, Lightburn has been an experience in patience and perseverance. From what I have done so far, (very little), I do like the potential of this program once I get all the wrinkles ironed out.
The problem that I seem to be having is the Get Position location. I set home and the system goes to the limit stops and does as expected. By rights, that should be 0,0,0. Next I move the laser into position (which in my case would be (1, 3.375, 2.75) I am now in position to begin my project, this should be my new 0,0,0 .
If I click on Get Position right after I start Lightburn and go to Home, according to Lightburn, starting home position is: X=12,Y=12,Z=3 and my Origin position is now X=12.908, Y=15.776 & Z=0.205. Now what happens when I start a project, I have a runaway system that shoots to the lower left corner (my home) and slams against the stops and continues to do this until I shut off the controller


I have included screen captures of my settings.
Thanks to all in advance for the help
Tim.

There’s a good chance that you have a workspace offset in place, which is common on CNC machines.

Type $# into the console and hit enter. You’ll see a bunch of output like this:
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]

Those are the workspace offsets. If they aren’t zeros that could be it. To zero them, type:

G10 L2 P2 X0 Y0 (and press enter)

Depending on where your limit switches are, and how the machine is configured, you might have a negative workspace area, and actually need an offset to use the positive coordinate space that LightBurn expects. You can read about the common issues and settings for laser use here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.