Home Position Negative and can't get X0 Y0 correct

I’ve just purchased Lightburn and am just trying to get it set up. I have an X-Carve 1000mm with a Tech 3.8W laser and GRBL 1.1f.

I have followed the JTech tutorial on setup, as well as added in $10=115 as I found in this forum as a recommended change that JTech missed. However, when I run my homing operation and click Get Position in the Move panel, it shows these negative numbers

I then try to move to X0.00 and Y0.00 and it moves my laser 343mm and 127mm into the middle of my workspace. For the life of me, I can’t figure out how to have my homing position set as X0 Y0!

Here are my GRBL settings.

$0=10
$1=255
$2=0
$3=3
$4=0
$5=0
$6=0
$10=0
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=25.000
$25=750.000
$26=250
$27=1.000
$30=2
$31=0
$32=0
$100=40.000
$101=40.000
$102=188.976
$110=8000.000
$111=8000.000
$112=500.000
$120=500.000
$121=500.000
$122=50.000
$130=790.000
$131=790.000
$132=100.000

here are the other 2 pics showing my settings if that helps

$30 should be either 255 or 1000 (LightBurn expects 1000, but it can be changed in the Device Settings)

$10 should be 0
$32 should be 1

Start with those and let me know if that sorts it out. If not, we’ll go from there.

1 Like

Sorry, I had copy/pasted incorrectly my GRBL. I do have those settings. The Macro I have set to turn on “laser mode” sets

$10=0
$30=255
$32=1

1 Like

Ah - it looks like the macro is missing the home offset, which would be G10 L2 P1 X-790 Y-790.

Then your “use CNC” macro would do:

G10 L2 P1 X0 Y0
$32=0
$10=255

1 Like

Thanks. Based on the previous photo of what my working size is, should I do G10 L2 P1 X-790 Y-790? Or should that X and Y be different?

The $130 and $131 settings in your machine are the maximum X and Y travel, and those are both set to 790mm, which is why I used those numbers.

Here’s a photo of how my laser is mounted. (brown line where the router bits go, red line where the laser is). Since the laser is mounted off center, it has a smaller working area than when carving wood.

Should I still use the 790x790? I turned the laser on and drew a rectangle for it’s max working area (with a little padding for comfort) and measured 692mm by 768mm . Should I put those numbers (or half those numbers since when I hit “go to origin” right now it goes to ~half of my working size?) as the X and Y?

Thanks for your attention

Those numbers are for moving the origin of the laser from the rear right to the front left. If you’re using the laser, you might want to change the “max travel” numbers ($130 and $131) (and/or the workspace size in LightBurn) to match what you measured for when you’re using the laser, but I don’t think the offset numbers should change, because you still need to move the origin by that much.

1 Like

Did this get fixed? Im right at the same issue you are. and am not sure if its a loose cable not enabling my machine to work properly.

Adding this to my “laser mode” macro did the trick

1 Like