Homing after Disabling Rotary

So Recently I started to learn how to engrave tumblers. Rotary used is from HM (Randy) and laser is black/yellow 7050 with Ruida and “60 watts”. Issue I run into is when switching rotary on and off is homing after rotary is disabled. It seems that in order for “proper” homing we need to do following:

  1. disable rotary,
  2. power down machine,
  3. Shut down Lightburn,
  4. Reopen lightburn,
  5. make sure Rotary stays “off”
  6. Power up machine.

Usually on step 6. for me it seems if I let it home end stop will never activate and axis will bump into it. On 2nd power cycle machine goes back to normal.

My question is, is there easier “procedure” than What I described above and/or is this like LB bug that could be corrected in future updates?

Thank you all.


I haven’t see this myself - If you have disconnected the rotary axis and connected the Y, and flipped the rotary switch to off in the settings, it should home properly when powered up and not need a 2nd power cycle.

Does anyone else have this happen when turning off the rotary setting? It’s the first I’ve heard of this.


To fully reset it lightburn also need to be shut down and re started in order to homing to occur properly. Unfortunately I cant upload short video showing what it is doing but maybe I could email it to you. Obviously there is workaround but could be annoying hence my question. And yes I’ve tried everything known until someone suggested to shut down LB as well and that gives it apart from initial crash on power up. As I said 2and power cycle is fine.

After using the rotary, change the setting, turn off the laser, exchange the rotary plug and power the laser back on?

I’ve done that many times but unless I restart lightburn itself it has irregular homing

but if you switch off your laser and turn it back home it should home? Nomatter which software you use.

It still h ok message but in a very weird way. I’ll see if I can attach video when i get home on pc

If you post it on YouTube as unlisted you can link here, or use google drive dropbox, or another service. It will only email if it’s less than 10mb.

Between 2 videos it’s like 8 mb. I will figure out how to post it

Same issue.
As Enno pointed, it works well when I turn off rotary before turning off the laser.
If I power cycle the machine before turning off the rotary, I must press RESET on the controller (ruida 6442g) after turning off the rotary. No need to restart Lightburn nor machine again.

Yes, if you remember when I had my software issue this is how it started. That is why I went into the machine settings, it would slam into the side and make an ungodly noise trying to home. But the way I stopped it is to write the machine rotary off before I logoff lightburn and shut down laser if that makes sense. the machine would stay in rotary like the software didn’t send the machine after I unchecked rotary

My steps

  1. Turn off rotary and write back settings to machine
  2. Turn off Machine
  3. Turn off Lightburn
  4. Unplug rotary and replug laser stepper
  5. Start Lightburn
  6. Start Machine and finds Home perfectly

seems about right what I had to do latest. I was hoping there should be simple fix in software itself

I’ve checked this and see no issue - However, there might be one difference: are you turning off the rotary setting from the rotary toggle on the main display, or from the Tools > Rotary Setup window? If you use the switch on the main display, before you change it, right-click the ‘Devices’ button in LightBurn to sync the settings with the controller.

If you power the controller after you run LightBurn, that toggle on the main display doesn’t get updated. When you go to Tools > Rotary Setup, it queries the controller when that window opens, so it’s always accurate. If I use that window to turn off the rotary, then power cycle the controller, it homes properly when starting up.

When I turn off the Rotary I do it through Tools->Rotary Setup window. After that, I turn off the machine and change the wires of the driver with a switch I’ve installed, and power the machine on again. No need for me to write changes to the controller nor exit from lightburn.

You don’t see it, but LightBurn does that automatically for you when you close the Rotary Setup window. :slight_smile:

Point for Lightburn :wink:

Thank you all for replies. I will update you all if something gets out of line with all these suggestions.

Appreciate your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.