Homing cycle not enabled in your Grbl settings

I have been using the rotary tool for the last couple weeks, need to go back to normal flat, i have turned off the enable rotary laser tool , rotary settings, but I’m getting this message in the console (Homing cycle is not enabled in your Grbl settings) I’m sure this is an easy fix but i have no clue where I set this back. Thanks

Type $$ on Lightburn console window and check if $22=1
if not just type $22=1 enter.

Okay i did enter $22=1, still giving me the same error message

Type $$ and copy/paste here the output.

Redid it and it worked thank, question so when I go back to rotary change back to (22=0)?

Yes. You can create a macro.

It does not really make sense to switch homing enable all the time. Just leave it activated ($22=1). You should turn off “auto home on startup”. Then, you just don’t click on the home button once the rotary is connected and can click on it when you use the laser normally.

1 Like

I do it the other way. I switch $22 and just ignore the homing fail message. Can’t switch Autohome with a macro, but can switch Home Enable.

That’s possible as well. Though personally, I don’t like auto home in general, since I don’t want the laser to start moving if I don’t specifically tell it to. :slight_smile: I want to have control all the time. :slight_smile:

Haha! With the little table top machines, that is not so much a worry.