Homing Direction Question

Have a question regarding setting homing direction. The machine I am working on requires homing to the back right and I would like to have the origin for operation back left.

Motion is working as expected when using the keypad however it want’s to default back left for it’s homing position. What I did was attempt to invert limiter polarity on the controller, but when I do so it will hit the Y limit and waits to home the X (and then does so slowly). Previously both axis would move to their limit switch locations simultaneously.

I note in the lightburn documentation there is mention of options to invert keypad direction, limiter polarity and direction polarity directly on the controller. If I change direction polarity and invert the keypad I’m where I need to be in homing operations and movement is correct in all directions.

My question is this. Does inverting the direction polarity and invert keypad direction change how the machine behaves when being sent gcode? IE, does the machine now think that left is right or are these settings simply for configuring the axis homing behavior?

You can check this for yourself. How does the laser respond when using the ‘Move’ tab controls? What happens when you send a small test, say with a few simple shapes, like a row of 4 10mm x 10mm squares, to the system?

(As a friendly side note, you have Ruida listed which does not use GCode, the protocol used is proprietary to their motion control systems.)

From my little experience with controllers. They are set to a specific coordinate system. One of the reasons that there is LmtX- and LmtX+, these tell the Ruida where it is, at Min limit or Max limit.

My Ruida homes to the rear left, anything towards me and right is a higher x or y value. From what I can tell, the machines that home on the rear right go positive forward and to the left. A different quadrant.

I tried this with my grbl board, had limits at both ends of each axis. Used it in a different quadrant.

Your console will give you the current X and Y.

Please report back your findings… :slight_smile:

:smiley_cat:

To have your machine’s 0,0 coordinate in the upper left, you will need to move the limit trigger from the upper right to the left and then adjust the X polarities accordingly.

I have extensively researched this in the past. I am confident there is no such configuration option to reverse the X axis coordinate opposite to the homing position designation. This means, there is no other way except for the steps above.