Homing Fail Help

Hello! I’m completely new to Lightburn and all Laser printing. I just got an Aufero L2-SF. I have MacOS.

I seem to have the printer set up just fine. I can use the move controls just fine, and they are well calibrated. However it cannot seem to find a home at all. I believe this model has no homing switches. Anytime I push “Home,” it just goes to the bottom left corner and jams up the motors for five seconds and then gives up. It gives the error:

ALARM:9
Homing Fail. Could not find limit switch within search distance. Defined as 1.5* max_travel on search and 5 * pulloff on locate phases.

I have toged off the setting “return home on start up”

I started it up with the laser head all the way in the bottom left, then typed “G92 X0 Y0”

I also typed in “$10=0”

It still can’t find home.

Any thoughts?

I’m not sure if I understand what it is you’re looking for. You’re already aware the machine does not having homing switches. That means your machine will not home on startup and you should not initiate a homing request.

How your machine is intended to work is that wherever the laser head happens to be at power-on will be set to 0,0. So your startup procedure becomes relevant.

Start your machine with the laser head at full front-left.

You needn’t do anything with G92 and you should re-enable $10=1.

I’m under the impression that I should be able to set x0 y0 and then start everything from there. Is that not the case?

The point is that you needn’t set x0 y0. The position at start-up is x0 y0. This is essentially a manual home.

Is there something specific that you’re trying to do that you would set x0 y0? This is normally done for systems that don’t start-up to 0,0.

So should I be able to push home and it goes to 00? Or is that not how it works?

No. You will never use the home button for your laser. If you want to go to 0,0 you can use the “Go to Origin” button which will default 0,0 unless you override it by setting a user origin in which case it will go to your user defined origin. That is done in Move window.

Alternatively, you could:

  1. type G0 X0 Y0 in Console.
  2. type 0,0 in Move window and push Go
  3. Save a position in Move window and push Go
  4. Jog to 0,0
  5. Use the Map looking tool to click on work area near 0,0
  6. Potentially add homing switches to your laser

Thank you so much! All the things I found from Lightburn said to go through those steps to set up “home.” I didn’t realize that. This makes much more sense.

Those steps are relevant for machines that start in a negative coordinate system so may not have been obvious which one applies to you.

The LightBurn Youtube video about the Sculpfun S9 largely applies to the Aufero and worth a watch. Here’s the part queued up to the part that talks about how to operate a laser without homing switches: