Homing issue after belt adjust

amongst other issues im having. ive adjusted my K40 x belt and now the machine has no idea where its at? Anyone got any suggestions. When i frame something its way off.

A little more detail would help:

  • What did you adjust?
  • What controller or firmware are you using?

It looks like it’s homing fine, and you’ve just got it in the wrong mode or wrong user origin - It looks like it’s trying to go left instead of right when you run the square. Check to make sure you’re either in Absolute Coords mode, or the Job Origin is on the left side, not the right.


I removed the belt inspected the teeth reinstalled it and tighten it up ever so slightly.

The controller in a Gerbil controller form awesome tech and the grbl firmware is 1.1e.

Any advice?

The X axis all moves normally. I can move it around the bed but look what happens when i tell the machine to go to a specific location:

Enabling soft limits displays this error in LB.

Starting stream


On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

Waiting for connection…

Waiting for connection…

Grbl 1.1e [’$’ for help]

Your Grbl may not support Variable Power mode (M4)

If your laser does not turn off between cuts,

You have the origin set to the upper-left. Is it supposed to be? Or is it supposed to be front-left like all the other K40 controllers?

Alarm: 2 means it’s trying to send your machine out of bounds. What were you trying to cut? Did you have overscan enabled, and was the object right up against the edge? We need a bit more information than you’re providing here in order to help you properly.

What happens if you try to use the “Click to position laser” tool? Just below the ‘A’ on the left side toolbar - If you select that and click around the workspace, the laser should follow the clicks.

I was carrying out some testing and power cycling the controller.

By chance it factory reset (known thing with the gerbil controller) since then it’s worked fine. I have no idea what caused it in the first place but I just want to thank you for your time and I will continue to buy and support light burn.

Also the pass through issue has been fixed by setting my $28=5.