Homing Issue on startup

Hello All, I have a Homing issue.

I’m trying to set up Auto Homing on start, in Lightburn, CronosMaker v1.98 board running GRBL v1.1h.

I’ve got switches hot glued in place temporarily, and i get a light on the switch when i push the lever. (connected to Y+ and X+)

Have done device setting, to Auto home on start, and also done the $22=1 and it saves ok.

With usb already attached, i turn on lightburn, then power up the board.

I get a [MSG: Caution: Unlocked]. i hope that is right.

what am i missing? something stupid i bet. (had the usual noob issues, and this is probably another one)