Homing issue with Ruida 6445G

I am in the middle of converting a FSL 5th Gen Hobby to a Ruida 6445G controller with larger tube and PSU.

I have the linear motion of the X/Y axes working correctly and have replaced the optical endstops with reed switch magnetic endstop (the wiring for the original endstops was damaged, and I had these on hand).

LEDs 2 and 4 light up on the Ruida panel when the X+ and Y+ endstops are triggered, but the machine just keeps crashing into the endstops when a homing procedure is performed. The laser head is traveling in the correct direction (top right) when told to home.

When I manually jog the laser using Lightburn, I can trigger the endstop protection on both X and Y when hitting the endstops, making me hit “ESC” on the control panel to unlock motion again.

I have tried setting the Home Offset for both X and Y to 5mm, but the laser never seems to be backing off after triggering the limit switches.

Any suggestions on what to try next?

You will probably have to tinker with the Vendor Parameters of the X/Y axes on the controller (via the controller interface itself or with LightBurn). On the controller it looks something like this:

grafik

If the polarity is not set correctly or the limit trigger/enable home is disabled than the homing will go wrong. I had the same issue while I have set up my machine with new end-stops quite a while ago. I can’t remember which exact change made the difference, but I do know that those settings were the problem on my machine.

My homing is in the top left corner, I have wired the limit sensors to the LmtX- and LmtY- terminals and here are my settings that are working fine (just for reference, you will need different settings for your machine):

Good luck and cheers,
Brian

I’ve verified that “Enable Home” is set for both axes, and I have inverted both limiter polarity in every possible configuration to no avail.

I’ve also tried connecting different, physical limit switches (Normally Open like the magnetic ones I’ve been using) to the Ruida control board, and actuating them by hand. These different switches behave identically to the magnetic switches, triggering the limit switch LED (and Y+/X+ in the diagnoses section of the Ruida LCD), but not the machine still just continues to crash when homing.

If home is the 0, 0 location, you should be using the LmtX- and LmtY- inputs for the limit switches. If you use LmtX+ and LmtY+ the Ruida ‘thinks’ ‘home’ is at MAX limits, not 0, 0.

Using NO switches is the proper connection with the ‘limiter polarity’ set to ‘false.’
Sounds like you have it pretty much down.

Generally when it crashes during the homing cycle is:

  1. Limit switch isn’t being detected
    or home cycle seek speed is too high for the machine to stop after it detects a limit
  2. Wrong direction to home.
  3. Coordinate system problem. (using the wrong set of Lmt*+/- inputs?)

Is there any possibility the they are not detecting the limits?
Not adjusted to detect at the proper point?
X & Y limit switches swapped at the controller? (check this first, I’ve done this :frowning: )

The replaced switches are very ‘slow’ compared to the original. I know on my little machine I had to change the ‘debounce’ time. Don’t know if that’s applicable to the Ruida.

Keep in mind that ‘active’ is designated by a logic ‘low’ on the pin. Based on 24v logic. This is also true of the outputs actually ‘sink’ current.

Limit switches ‘pull down’ the line to ‘low’, the same with water protection (WP) and other inputs.

Good luck :slight_smile:

Looks like the controller was actually looking for X- and Y- after all. Swapping to the same limit switches hooked up to those endstop inputs is working great!

1 Like

I was suspicious that may have been the case. It’s kind of misleading, but it’s Chinese and their ‘funny’ English is better than my best Chinese…

Glad that fixed you up.

You should check this ‘solved’ if that’s the case.

Take care… :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.