Homing issues on setup of Roly Lasermatic xw

When setting up this unit, I keep getting the following code: Alarm 9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
ok
Grbl 1.1h [‘$’ for help]

The machine makes a horrible sound when homing. Any thoughts?

PLENTY OF THOUGHTS.

The laser has not been configured properly. It is likely trying to Home where there are no switches. This can be either Homing in the wrong corner, or there are no switches to Home on.

Confirm you have switches, most likely in the front left corner.
With the laser module in the middle when you power it up, does it travel toward those switches when Homing?
If no switches, set GRBL parameter $22=0. Home is then the location of the laser module whenever you power up the machine.

This should help you clear up the Alarm 9 issue. We will be here for your next question.

Try jogging the laser module by hand until it hits the limit switches if out of reach adjust switch position accordingly.

Did you reset the $130 and $131 to the new bed size ?

I have managed to fix the issue after watching the Roly video on the collet being shifted during transport. Moving on with the set up now. Thanks for the comments and advice!

1 Like

Hi, I just got my laser today and I am going through the initial setup and I have encountered the same problem. When The laser moves to position itself , it sounds smooth but when I give it a point to go to that origin, it makes a nasty noise, like grinding gears.
What was the video you mentioned that solved it? I cant seem to find a solution.
" I have managed to fix the issue after watching the Roly video on the collet being shifted during transport. Moving on with the set up now. Thanks for the comments and advice!" Thanks in advance!