Homing Max 3 Neje

Hi All, back in 2020 I had a post about homing a Neje. I did see the attached from Rick suggesting Neje had not gotten back to him.

I have now just upgraded my Neje Max 2S to the Max 3. I am as yet unable to update the firmware as both Neje software and Neje Grbl Uploader will not connect to the new board. The problem is when I install the Neje newest version software it homes to the ‘Front LEFT’ fails and then the software quits. the Grbl uploader says device not recognized.
I have turned OFF Auto Home in Lightburn and have manually configured “home” in the move tab - so I can start up lightburn and actually work with the laser.

I have set back left for home position. I have configured Origin to be back left.

Is there anything other than a firmware update I can do to set it to home back left? Just wondering if I may have missed any steps… I did run it last night and the head moves a LOT faster now and I did cut out a circle without issue … just can’t home it properly

I believe there is new software for Max 3 controller boards. You may want to check for newer software.

I believe Max 3 should home back-left. However, your origin should be front-left/bottom-left, not back-left as you have setup in Device Settings.

If your machine is homing front-left something is odd. Did you change any Neje configuration settings?

It’s trivial to change homing direction but want to confirm what caused this.

Can you run these commands in Console and return results:


Thank You All for the replies. I did manage to correct the issue with the help of Neje support last night. When I received the new board there were NO INSTRUCTIONS with it. After going back and forth several times support sent me two images side by side of old and new board. I noted that the cable positions had been changed! So after I swapped Y-L and Y-R all is working exactly as it should be the laser now homes properly and I have confirmed the firmware is up todate as well as running the newest versions of the software. Thanks all for taking the time. I have however noticed something I did not see previously, on starting lightburn and connecting to the com port - it will tell me the device is NOT IN GRBL Mode so I have to unplug from USB and Power - plug power - plug USB and it then comes online in lightburn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.