Homing on job start

Rank beginner here, I’m sure my issue is not new, but my searching hasn’t found the answer.

I have a Comgrow Z1 grbl machine.

Every time I try to send a job to the laser, the machine moves to the home position at the upper right, trips a limit switch, and stops.

This machine is also a router. I had the same issue when using the router head, and stopped that by removing the autohome (G28) command from the gcode file.

I can’t figure out where I would do the same in LaserGRBL or Lightburn.

Thanks

Just out of curiosity, what is your $27 set to? Often it is set to something like this “$27=1.000 ; homing pull-off, mm” which on my machine (a 3018 Pro) was not enough, and I had to change it to 3 ($27=3.000) to get it far enough away from the limit switch. Perhaps you could post your grbl settings (type $$ in the command line and hit enter) and then folks can chime in.

Paul:
$$

$0=10

$1=25

$2=0

$3=6

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=400.000

$101=400.000

$102=400.000

$110=800.000

$111=800.000

$112=500.000

$120=500.000

$121=500.000

$122=500.000

$130=180.000

$131=300.000

$132=45.000

ok

I’ll experiment with that, Thanks

I’ve got it working, there was a setting missing in the manual from the manufacturer, the “Start From” setting. Once I got that correct it started working.

That said, the pull off settings is too close, so I will be experimenting with that.

Thanks,