Homing Position does not work


i use Lightburn with a CNC3018 which works perfectly.
Only one thing does not work: Automatically moving to home position.

I have Limit Switches installed on all axis and they all work,
In GRBL Machine Settings I have set $21 and $22 to 1.

Problem: When i press the Home Position Button (German Text is “Startpunkt”) the machine starts moving the Z.Axis to top position and does not stop, even when the top limit switch is actuated.

Questions are:

  • Why does the limit switch not work her (it works when i manually actuate it in normal operation=
  • Can i deactivate the z-Axis so that it is not involved in Home Position Run?

Thank you for support.
Best wishes


Edit: Another Problem.
Also, if i move the machine with $21 and $22 set to 1 it suddenly stops after a few millimeters althought no limit switch is actuated.

That’s the start of the GRBL homing sequence: it moves the tool away from the work surface. When the Z axis homes successfully, GRBL will then home the X and Y axes. Conversely, if Z doesn’t succeed, all homing will fail, the machine doesn’t know where it is, and most motions will cause an error.

Unfortunately, disabling Z homing requires recompiling GRBL.

Perhaps the Z axis hardware doesn’t quite activate the switch before jamming at the end of its travel, so it only looks good.

A fraction of a millimeter matters!

You did not say, but I am guessing you have mechanical micro switches.

  1. Check the switch mounting screws. If loosened, the switch can rotate a bit to move the Z axis trip point. This is especially possible if the machine also serves as a CNC mill that vibrates a lot.
  2. Check the connections at the switch terminals. Tiny wires break easily.
  3. Check the switch wire connections at the controller board. Those push-on connectors are often not that snug.

This pretty much covers all the mechanical, and the most likely, possibilities.


thank you for the answers.

I think I can exclude mechanical causes.
Please have a look at the video:

When I move the Z-axis manually and press the switch with my finger, the machine stops immediately.
If the travel to the home position was started and I press the switch, the control does not care at all - the Z-axis just keeps running ;-(

Other ideas?

Best wishes

Make sure that the Z-limit switch is indeed wired to the Z-limit input on your controller. Seems to me that you may be input to another axis.

Omg, you’re right;-)
It looks like I had the plugs plugged in wrong during one of the thousand rebuilds.
At this point I have not even looked. Thanks for pointing out this stupid mistake :slight_smile:

And thank you for being willing to admit that!

Although it’s embarrassing, when you find such a self-inflicted mistake, you just know the fix is going to work … :grin:

Bad me! I did not notice his message did not have the “suddenly stopped working” part.
4. Hope somebody besides me reads these messages.


That could have easily have been me as well until I watched the video. The giveaway was that the switch worked during normal operation, but not while homing Z-axis specifically.

I just watched the video and it makes no sense to me. GRBL knows it is only a switch or not. The Z up limit switch serves both overtravel and home position. Wrong connections on the controller board should have made it fail in both cases.

My opinion, based on the video, is that limit switches were enabled in the parameters, but the home parameter was not. Anyhow, glad he is up and running.

Either we do not have the full story or I need to be schooled.

If the Z-switch were wired to X or Y inputs the controller would think that X or Y is being actuated during normal operation. That would cause a hard limit fault. But essentially any switch being activated would cause the fault, it need not be the Z-switch. This is why the switch worked to stop the machine in that scenario.

On homing, Z-axis attempts to home first. In order to complete homing for Z the controller is expecting switch activation specifically on the Z-limit. Since the switch was actually activating X or Y Z-homing did not recognize that the Z-limit had been reached so attempted to continue until the crash.

1 Like

Yes, that could happen. My controller board has two pairs of pins for X any Y (2 input & 2 gnd), and one for the Z axis. If Z was swapped with X or Y, what you describe would happen. Funny how we can screw it up when we get in a hurry.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.