Homing problem with ruida


I am having a problem with my laser. While homing, gantry Will go past the limit switches. I tested the limit switches with metal - they work. On the diagnosis Page on the controler, they also light up. What could be the problem?

Bellow is the photo of my vendor settings in lightburn.


They work when you test them, but it sounds like the piece they are supposed to be sensing is too far away from the sensor. The gap needs to be as small as you can make it. I have mine set with about a 2mm gap. Don’t know if it makes a difference, but both of mine are set for the metal tab to be over then end of the sensor, not the side.

thank you for your reply, but they work even when gantry passes them.

Had to move my limit switches for some modifications. They usually specify within 3 - 5mm of the sensor.

Is this a new machine?

I.E. has it ever worked?

The limit switches will pull the LmtX- (CN4 - pin 4) low, indicating an ‘active’ trigger. The controller will back off the limit a specified amount and re-engage the limit at a slower speed to get as accurate as possible ‘home’.

It sounds like the switch is working and it’s wired properly to the controller, if you are watching the proper LED on the controller react to it.

I don’t know for sure, but I would think the display LEDs are on the controllers buffered side, so I’d expect the signal to be getting to the hardware in the controller.

I think we need more information of how it is acting.

You can do a ‘manual’ home by starting the machine, X axis example. Move the head to the center or opposite side of the machine. Power up/reset and touch the sensor with a screwdriver or other metal object. That axes should stop, back up and then move back to the sensor. When it starts to move back, touch the sensor a second time to tell the controller it has homed properly.

Just for diagnosis purposes. Keep the extra finger on the ‘esc’ key so if it doesn’t stop when you touch the limit you can halt the homing process in the controller.

Good luck


Thank you very much for your help so far.

Machine worked fine before.
I tried, when i touch the fixed limit switch while homing, the laser reacts to it and homes, but when i touch the switch on the X axe, laser doesnt reacts, even tho the light on i turns on.

Thanks for your answers and best regards

I shold also add i get hard limit prot message on the controler (for the X axe) only at the bottom half of the machine. On the top half, laser can go to the side until it hits gantry.

When i did some additional tests, i found out thaht machine homes properly, but ONLY if restarted when the head is in the bottom half of the machine.
very strange

Seems like an odd message. Usually the ‘hard limits’ (Lmt*+) are not used on these machines. I will have to fiddle with mine and see that message.

Does the control panel show it has homed properly when you get it to work?

What are your x, y and z values on the machines console?

If you push the head out of range, the Ruida might abort the homing sequence if the head moves further than the machines ‘workspace’ is set.


When i get it to home properly, XY values are OK - when it homes (from the bottom), values are 0. Ive set workspace to 520x700 mm.
I dont understand why it only homes if started up from the bottom

Beats me… Some smells…

When it homes from the the front/right properly, does it actually do the following?

move to the limit switch. After it lights it should back off the limit.
it will then slowly move back to the limit switch for a more accurate home.

Does it do this?

If it’s doing this from the front/right and it homes to the rear/left… got me wondering.

Or do you mean anywhere on the bottom half of the machine workspace?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.