Horizontal and vertical cut lines not joining up correctly

We’re having a problem cutting some relatively simple shapes whereby the horizontal and vertical lines just don’t align using Lightburn (v0.9.07) with a Ruida controller (mainboard version RDLC-V8.01.56) on a Bodor laser machine. It works just find using our older laser machine using LaserCut5.3… File was originally created in Inkscape.

Note: each of the puzzle pieces in this example are bridged on all sides and we have tried both with and without bridges with little success.

Any ideas?

Would need to evaluate the source image to really understand, but it looks like there are breaks in the link segments. Almost like this was created by duplicating the heart shaped line segment but not getting the alignment correct. This can also be caused when using an image, duplicated in a pattern, where the edges of the images overlap. This can cause what you are seeing as well. You will notice the gaps from you burn are in the same pattern as the gaps in the source art.

image

Post these files and we can take a closer look.

“It works just fine on our old machine” doesn’t say much, unless the two controllers are connected to identical machines and have identical settings for acceleration, max speed, etc. Even then, different path planning order can highlight overly aggressive settings.

As Rick suggests though, post the original just so we can rule out issues with the file. If you run it in the preview that will show you what’s going to be sent to the laser (click the top toolbar button that looks like a TV monitor). If it looks right there, but not on the machine, chances are it’s the machine losing steps. If it looks wrong in the preview there might be an issue with the file (or how LightBurn interprets it).

Thanks Oz

To address the “It works just fine on our old machine” just indicates that it’s less likely that there is a problem with the cut file however we’re not seeing this problem with “standard” puzzle pieces just these new ones. Running through the preview seems to indcate that everything should cut fine. I wondering if there is a problem with the controller and am just trying to see if I’ve missed anything - don’t really want to buy a new controller but as this is our main cutting machine if we have to then so be it. We have had other issues with the alignment particularly when scanning and cutting intricate shapes. Just trying to rule out as much as possible.

There are breaks or bridges in each piece - we cut thousands of puzzle shapes and this stops them falling out. As I mentioned in my inital post we tried this both with and without brides (or tags if you prefer) with the same or similar results. Puzzle.lbrn (3.4 MB)

I’ve uploaded a lightburn file with both bridged and unbridged.

Any help or guidance gratefully received.

I don’t think it’s an issue with the file, just a settings issue - The file itself has lots of very small, sharp moves, so it’s likely just the right arrangement of shapes to trigger a problem you have. From the first image you showed, it looks like the leftmost and lower lines are shifted from lost steps.

In Edit > Machine settings, check the acceleration values for Idle Speed and Idle Acceleration. Those are how fast it will move between cuts, and how fast it will accelerate for those moves. I would start by lowering the acceleration by about 25% and try the file again to see if it’s still shifting.